arc: Add support for ARC-specific binutils
authorMischa Jonker <mischa.jonker@synopsys.com>
Thu, 2 May 2013 09:51:25 +0000 (09:51 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 4 May 2013 21:07:44 +0000 (23:07 +0200)
ARC support is not upstream yet.

Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/binutils/2.19-arc/add-empty-info-files.patch [new file with mode: 0644]
package/binutils/Config.in.host
package/binutils/binutils.mk

diff --git a/package/binutils/2.19-arc/add-empty-info-files.patch b/package/binutils/2.19-arc/add-empty-info-files.patch
new file mode 100644 (file)
index 0000000..90de429
--- /dev/null
@@ -0,0 +1,72 @@
+binutils: add empty info files to remove makeinfo dependency
+
+Signed-off-by: Mischa jonker <mjonker@synopsys.com>
+---
+ bfd/doc/bfd.info           |    1 +
+ binutils/doc/binutils.info |    1 +
+ etc/configure.info         |    1 +
+ etc/standards.info         |    1 +
+ gas/doc/as.info            |    1 +
+ gprof/gprof.info           |    1 +
+ ld/ld.info                 |    1 +
+ 7 files changed, 7 insertions(+), 0 deletions(-)
+ create mode 100644 bfd/doc/bfd.info
+ create mode 100644 binutils/doc/binutils.info
+ create mode 100644 etc/configure.info
+ create mode 100644 etc/standards.info
+ create mode 100644 gas/doc/as.info
+ create mode 100644 gprof/gprof.info
+ create mode 100644 ld/ld.info
+
+diff --git a/bfd/doc/bfd.info b/bfd/doc/bfd.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/bfd/doc/bfd.info
+@@ -0,0 +1 @@
++
+diff --git a/binutils/doc/binutils.info b/binutils/doc/binutils.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/binutils/doc/binutils.info
+@@ -0,0 +1 @@
++
+diff --git a/etc/configure.info b/etc/configure.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/etc/configure.info
+@@ -0,0 +1 @@
++
+diff --git a/etc/standards.info b/etc/standards.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/etc/standards.info
+@@ -0,0 +1 @@
++
+diff --git a/gas/doc/as.info b/gas/doc/as.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/gas/doc/as.info
+@@ -0,0 +1 @@
++
+diff --git a/gprof/gprof.info b/gprof/gprof.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/gprof/gprof.info
+@@ -0,0 +1 @@
++
+diff --git a/ld/ld.info b/ld/ld.info
+new file mode 100644
+index 0000000..8b13789
+--- /dev/null
++++ b/ld/ld.info
+@@ -0,0 +1 @@
++
+-- 
+1.7.0.4
+
index a61a5035336f481c4f0d6a903d46e2b594c2c4d5..d9bab441f0b0fe9feae5986f3e4fb4a2572bba30 100644 (file)
@@ -2,6 +2,7 @@ comment "Binutils Options"
 
 choice
        prompt "Binutils Version"
+       depends on !BR2_arc
        default BR2_BINUTILS_VERSION_2_21 if (BR2_mips || BR2_mipsel || BR2_sh)
        default BR2_BINUTILS_VERSION_2_21_1 if (!BR2_UCLIBC_VERSION_0_9_31)
        default BR2_BINUTILS_VERSION_2_21
@@ -41,6 +42,7 @@ endchoice
 config BR2_BINUTILS_VERSION
        string
        default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
+       default "2.19-arc"      if BR2_arc
        default "2.20.1"        if BR2_BINUTILS_VERSION_2_20_1
        default "2.21"          if BR2_BINUTILS_VERSION_2_21
        default "2.21.1"        if BR2_BINUTILS_VERSION_2_21_1
index 92e0a74836507f9e00b7385808ff79f07357d33d..081be6ad4b38c8c8313af8c42277513b46a058d5 100644 (file)
@@ -26,6 +26,9 @@ BINUTILS_SITE = $(BR2_GNU_MIRROR)/binutils
 ifeq ($(ARCH),avr32)
 BINUTILS_SITE = ftp://www.at91.com/pub/buildroot
 endif
+ifeq ($(BR2_arc),y)
+BINUTILS_SITE = $(BR2_ARC_SITE)
+endif
 BINUTILS_EXTRA_CONFIG_OPTIONS = $(call qstrip,$(BR2_BINUTILS_EXTRA_CONFIG_OPTIONS))
 BINUTILS_INSTALL_STAGING = YES
 BINUTILS_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
@@ -52,7 +55,11 @@ HOST_BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
                        --with-sysroot=$(STAGING_DIR) \
                        $(BINUTILS_EXTRA_CONFIG_OPTIONS)
 
+ifeq ($(BINUTILS_VERSION),2.19-arc)
+HOST_BINUTILS_DEPENDENCIES = host-flex host-bison
+else
 HOST_BINUTILS_DEPENDENCIES =
+endif
 
 # We just want libbfd and libiberty, not the full-blown binutils in staging
 define BINUTILS_INSTALL_STAGING_CMDS