package/p11-kit: libtasn1 is optional, not mandatory
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 21 Dec 2020 12:36:18 +0000 (13:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 29 Dec 2020 19:57:46 +0000 (20:57 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/p11-kit/Config.in
package/p11-kit/p11-kit.mk

index 56904187566a215581f3e010b041e0c2b18c79fc..9be76c2f41c354808f3e901e152fc2d313432fca 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_P11_KIT
        depends on !BR2_STATIC_LIBS
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       select BR2_PACKAGE_LIBTASN1
        help
          Provides a way to load and enumerate PKCS#11 modules.
          Provides a standard configuration setup for installing PKCS#11
index fef479183166efb1a9b14241238df8dea8bf96e0..c2a7b23e9d782bee6360f6686e2334c3726ea8b2 100644 (file)
@@ -6,7 +6,6 @@
 
 P11_KIT_VERSION = 0.23.16.1
 P11_KIT_SITE = https://github.com/p11-glue/p11-kit/releases/download/$(P11_KIT_VERSION)
-P11_KIT_DEPENDENCIES = host-pkgconf libtasn1
 P11_KIT_INSTALL_STAGING = YES
 P11_KIT_CONF_OPTS = --disable-static
 P11_KIT_CONF_ENV = ac_cv_have_decl_program_invocation_short_name=yes \
@@ -27,4 +26,11 @@ else
 P11_KIT_CONF_OPTS += --without-libffi
 endif
 
+ifeq ($(BR2_PACKAGE_LIBTASN1),y)
+P11_KIT_DEPENDENCIES += host-pkgconf libtasn1
+P11_KIT_CONF_OPTS += --with-libtasn1
+else
+P11_KIT_CONF_OPTS += --without-libtasn1
+endif
+
 $(eval $(autotools-package))