Fix fallout after generated defconfig support
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 23 Dec 2015 08:37:36 +0000 (09:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Dec 2015 08:54:14 +0000 (09:54 +0100)
Fix improper use of qstrip; use correct variables.

Fixes #8546.

Reported-by: craigswank@gmail.com
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/at91bootstrap3/at91bootstrap3.mk
boot/barebox/barebox.mk
linux/linux.mk

index 0f5d3bdb9c4aa65451a9f928de977b0aec94d765..32732f475824fe4bab3d46c6f96eb8ba606b56fe 100644 (file)
@@ -57,7 +57,7 @@ ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_USE_DEFCONFIG),y)
 # We must use the user-supplied kconfig value, because
 # AT91BOOTSTRAP3_KCONFIG_DEFCONFIG will at least contain
 # the trailing _defconfig
-ifeq ($(AT91BOOTSTRAP3_KCONFIG_DEFCONFIG),)
+ifeq ($(call qstrip,$(BR2_TARGET_AT91BOOTSTRAP3_DEFCONFIG)),)
 $(error No at91bootstrap3 defconfig name specified, check your BR2_TARGET_AT91BOOTSTRAP3_DEFCONFIG setting)
 endif
 endif
index f36ca70f6e9d80bed5fb2dbba6383588759db110..7715dafe61861c6020e9cb2cadaf42a2e4df1701 100644 (file)
@@ -112,7 +112,7 @@ ifeq ($(BR2_TARGET_BAREBOX)$(BR_BUILDING),yy)
 # We must use the user-supplied kconfig value, because
 # BAREBOX_KCONFIG_DEFCONFIG will at least contain the
 # trailing _defconfig
-ifeq ($(or $(BAREBOX_KCONFIG_FILE),$(BAREBOX_KCONFIG_DEFCONFIG)),)
+ifeq ($(or $(BAREBOX_KCONFIG_FILE),$(call qstrip,$(BR2_TARGET_BAREBOX_BOARD_DEFCONFIG))),)
 $(error No Barebox config. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG or BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE settings)
 endif
 endif
index 06a27ebed272b069f3546c8db77666e1463d50b9..69a09aa2063140c6496d22674dfb2e61e517ff35 100644 (file)
@@ -405,7 +405,7 @@ ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
 # We must use the user-supplied kconfig value, because
 # LINUX_KCONFIG_DEFCONFIG will at least contain the
 # trailing _defconfig
-ifeq ($(qstrip $(BR2_LINUX_KERNEL_DEFCONFIG)),)
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
 $(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)
 endif
 endif