package/x11r7/xserver_xorg-server: add sysv init script
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 29 Apr 2017 20:56:43 +0000 (22:56 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 31 Mar 2018 13:56:31 +0000 (15:56 +0200)
We need ":0.0 vt01" to make sure Xorg finds the correct terminal.

Quoting https://www.x.org/archive/X11R6.8.0/doc/Xorg.1.html

-allowMouseOpenFail
    Allow the server to start up even if the mouse device can't be
    opened or initialised.

We need this option in case BR2_PACKAGE_XDRIVER_XF86_INPUT_MOUSE was
not enabled.

-noreset
    prevents a server reset when the last client connection is closed.

We need this option to prevent auto-close of Xorg.

Tested with a qemu image and Kodi.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Arnout: copy an abbreviate version of the explanation above to the
         script.]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/x11r7/xserver_xorg-server/S40xorg [new file with mode: 0755]
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

diff --git a/package/x11r7/xserver_xorg-server/S40xorg b/package/x11r7/xserver_xorg-server/S40xorg
new file mode 100755 (executable)
index 0000000..215c0b7
--- /dev/null
@@ -0,0 +1,46 @@
+#!/bin/sh
+#
+# Starts Xorg
+#
+
+BIN=/usr/bin/Xorg
+PIDFILE=/var/run/xorg.pid
+
+# ":0.0 vt01" makes sure Xorg finds the correct terminal.
+# -allowMouseOpenFail allows the server to start up even if the mouse device
+#   can't be opened or initialised.
+# -noreset prevents a server reset when the last client connection is closed.
+XORG_ARGS=":0.0 vt01 -s 0 -noreset -allowMouseOpenFail"
+
+start() {
+       printf "Starting Xorg: "
+       start-stop-daemon -S -q -b -m -p $PIDFILE --exec $BIN -- $XORG_ARGS
+       [ $? = 0 ] && sleep 3 && echo "OK" || echo "FAIL"
+}
+
+stop() {
+       printf "Stopping Xorg: "
+       start-stop-daemon -K -q -p $PIDFILE
+       [ $? = 0 ] && echo "OK" || echo "FAIL"
+}
+
+restart() {
+       stop
+       sleep 2
+       start
+}
+
+case "$1" in
+       start)
+               start
+       ;;
+       stop)
+               stop
+       ;;
+       restart|reload)
+               restart
+       ;;
+       *)
+               echo "Usage: $0 {start|stop|restart}"
+       exit 1
+esac
index 45a2c81f2b883fbb83fbce50cac64146dc1c91b5..d605a2c7425f1c1f9a2b65005e703f21750b915a 100644 (file)
@@ -258,4 +258,9 @@ XSERVER_XORG_SERVER_CONF_OPTS += --with-sha1=libsha1
 XSERVER_XORG_SERVER_DEPENDENCIES += libsha1
 endif
 
+define XSERVER_XORG_SERVER_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 755 package/x11r7/xserver_xorg-server/S40xorg \
+               $(TARGET_DIR)/etc/init.d/S40xorg
+endef
+
 $(eval $(autotools-package))