bcm2835: new package
authorPeter Seiderer <ps.report@gmx.net>
Tue, 8 Dec 2015 21:23:44 +0000 (22:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Dec 2015 21:54:15 +0000 (22:54 +0100)
[Thomas:
 - addition of 'depends on BR2_arm' as suggested by Yann.
 - addition of a comment in the Config.in help text that says that
   this library is a pure abomination.
 - fix the hash, since apparently upstream changes the released
   tarballs after they are published.
 - fix license, it's GPLv2, not GPLv2+.]

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/bcm2835/Config.in [new file with mode: 0644]
package/bcm2835/bcm2835.hash [new file with mode: 0644]
package/bcm2835/bcm2835.mk [new file with mode: 0644]

index 283363d9f9b1815b8464634f90d4b95d43d981f7..bc6099d1a3fc78cdc9090bd2b62092322eedee03 100644 (file)
@@ -906,6 +906,7 @@ menu "Graphics"
 endmenu
 
 menu "Hardware handling"
+       source "package/bcm2835/Config.in"
        source "package/c-periphery/Config.in"
        source "package/ccid/Config.in"
        source "package/dtc/Config.in"
diff --git a/package/bcm2835/Config.in b/package/bcm2835/Config.in
new file mode 100644 (file)
index 0000000..4c3eb2c
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_BCM2835
+       bool "bcm2835"
+       depends on BR2_arm
+       help
+         C library for Broadcom BCM 2835 as used in Raspberry Pi.
+         It provides access to GPIO and other IO functions on the
+         Broadcom BCM 2835 chip, allowing access to the GPIO pins
+         on the 26 pin IDE plug on the RPi board so you can control
+         and interface with various external devices.
+
+         WARNING: the opinion of the Buildroot developers is that
+         such library is a complete abomination as it entirely works
+         around the standard Linux interfaces to access GPIOs, I2C,
+         SPI busses or other IOs. The library directly remaps the
+         hardware registers in user-space, completely bypassing what
+         the kernel drivers are doing, and potentially conflicting
+         with them.
+
+         http://www.airspayce.com/mikem/bcm2835
diff --git a/package/bcm2835/bcm2835.hash b/package/bcm2835/bcm2835.hash
new file mode 100644 (file)
index 0000000..1aea3ae
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 295f66dab533592ce41db8e07befe985645a2e661bbf75dce9c383e61e24cb5f bcm2835-1.48.tar.gz
diff --git a/package/bcm2835/bcm2835.mk b/package/bcm2835/bcm2835.mk
new file mode 100644 (file)
index 0000000..c111a0a
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# bcm2835
+#
+################################################################################
+
+BCM2835_VERSION = 1.48
+BCM2835_SITE = http://www.airspayce.com/mikem/bcm2835
+BCM2835_LICENSE = GPLv2
+BCM2835_LICENSE_FILES = COPYING
+BCM2835_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))