package/mpd: add fluidsynth optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 15 Jul 2020 21:57:34 +0000 (23:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Aug 2020 21:30:45 +0000 (23:30 +0200)
fluidsynth is an optional dependency of mpd since version 0.18.5 and
https://github.com/MusicPlayerDaemon/MPD/commit/727c6226597fb710239b14e7985d97ec6b53f0ee

It is enabled by default

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index e9e7b83cbd892efd30a8d3bd4a50cadb5c7a6065..1b3ab8fa5d3d7da94ae68a36fb3cf93a8be08081 100644 (file)
@@ -114,6 +114,16 @@ config BR2_PACKAGE_MPD_FLAC
          Enable flac input/streaming support.
          Select this if you want to play back FLAC files.
 
+config BR2_PACKAGE_MPD_FLUIDSYNTH
+       bool "fluidsynth"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_FLUIDSYNTH
+       help
+         Enable fluidsynth MIDI decoder support.
+
+comment "fluidsynth support needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
+
 config BR2_PACKAGE_MPD_LIBSNDFILE
        bool "libsndfile"
        select BR2_PACKAGE_LIBSNDFILE
index a1fa4b0a5e48e53f1750a60b0d38e4498105d724..b8df04f08405f38902a4afcb3c593b078ca28174 100644 (file)
@@ -97,6 +97,13 @@ else
 MPD_CONF_OPTS += -Dflac=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_FLUIDSYNTH),y)
+MPD_DEPENDENCIES += fluidsynth
+MPD_CONF_OPTS += -Dfluidsynth=enabled
+else
+MPD_CONF_OPTS += -Dfluidsynth=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_HTTPD_OUTPUT),y)
 MPD_CONF_OPTS += -Dhttpd=true
 else