package/libva: bump version to 2.6.1
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 31 Jan 2020 16:26:22 +0000 (17:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 1 Feb 2020 22:45:33 +0000 (23:45 +0100)
Removed patch which was applied upstream:
https://github.com/intel/libva/commit/69b4230c36d977d4198d74a5f1fc7529715fd5ab

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libva/0001-adjust-call-sequence-to-ensure-authenticate.patch [deleted file]
package/libva/libva.hash
package/libva/libva.mk

diff --git a/package/libva/0001-adjust-call-sequence-to-ensure-authenticate.patch b/package/libva/0001-adjust-call-sequence-to-ensure-authenticate.patch
deleted file mode 100644 (file)
index 09c7664..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-From a80d2fe3bcc2c14c6e1434615d1be38924b668ea Mon Sep 17 00:00:00 2001
-From: Carl Zhang <carl.zhang@intel.com>
-Date: Mon, 30 Dec 2019 04:38:43 -0500
-Subject: [PATCH] adjust call sequence to ensure authenticate operation is
- executed
-
-fixes #355
-
-Downloaded from upstream PR: https://github.com/intel/libva/pull/356
-
-Signed-off-by: Carl Zhang <carl.zhang@intel.com>
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- va/va.c | 25 ++++++++++++++++---------
- 1 file changed, 16 insertions(+), 9 deletions(-)
-
-diff --git a/va/va.c b/va/va.c
-index cfcabff..7f014a1 100644
---- a/va/va.c
-+++ b/va/va.c
-@@ -367,11 +367,23 @@ static VAStatus va_getDriverNameByIndex(VADisplay dpy, char **driver_name, int c
-     VADisplayContextP pDisplayContext = (VADisplayContextP)dpy;
-     const char *driver_name_env = NULL;
-     VADriverContextP ctx;
-+    VAStatus status = VA_STATUS_SUCCESS;
-     ctx = CTX(dpy);
-+    if (pDisplayContext->vaGetDriverNameByIndex) {
-+        /*if vaGetDriverNameByIndex is implemented*/
-+        status = pDisplayContext->vaGetDriverNameByIndex(pDisplayContext, driver_name, candidate_index);
-+    } else {
-+        if (candidate_index == 0)
-+            status = pDisplayContext->vaGetDriverName(pDisplayContext, driver_name);
-+        else
-+            status = VA_STATUS_ERROR_INVALID_PARAMETER;
-+    }    
-     driver_name_env = getenv("LIBVA_DRIVER_NAME");
-     /*if user set driver name by vaSetDriverName */
-     if (ctx->override_driver_name){
-+        if(*driver_name)
-+            free(*driver_name);
-         *driver_name = strdup(ctx->override_driver_name);
-         if (!(*driver_name)) {
-               va_errorMessage(dpy, "va_getDriverNameByIndex  failed with %s, out of memory\n",vaErrorStr(VA_STATUS_ERROR_ALLOCATION_FAILED));
-@@ -380,19 +392,14 @@ static VAStatus va_getDriverNameByIndex(VADisplay dpy, char **driver_name, int c
-         va_infoMessage(dpy, "User requested driver '%s'\n", *driver_name);
-         return VA_STATUS_SUCCESS;
-     } else if (driver_name_env && (geteuid() == getuid())) {
-+        if(*driver_name)
-+            free(*driver_name);
-         /*if user set driver name by environment variable*/
-         *driver_name = strdup(driver_name_env);
-         va_infoMessage(dpy, "User environment variable requested driver '%s'\n", *driver_name);
-         return VA_STATUS_SUCCESS;
--    } else if (pDisplayContext->vaGetDriverNameByIndex) {
--        /*if vaGetDriverNameByIndex is implemented*/
--        return pDisplayContext->vaGetDriverNameByIndex(pDisplayContext, driver_name, candidate_index);
--    } else {
--        if (candidate_index == 0)
--            return pDisplayContext->vaGetDriverName(pDisplayContext, driver_name);
--        else
--            return VA_STATUS_ERROR_INVALID_PARAMETER;
--    }
-+    } 
-+    return status;
- }
- static char *va_getDriverPath(const char *driver_dir, const char *driver_name)
index d3a4f51ff6b0c16da55a204bcf481368821b16d5..8edacf12893bb779618677d64107280f386083bd 100644 (file)
@@ -1,5 +1,5 @@
-# From https://github.com/intel/libva/releases/download/2.6.0/libva-2.6.0.tar.bz2.sha1sum
-sha1 9d3b55d2a01e45612c03b2e7718599e760c3bf7e  libva-2.6.0.tar.bz2
+# From https://github.com/intel/libva/releases/download/2.6.1/libva-2.6.1.tar.bz2.sha1sum
+sha1 6b218e5622174a37fd0cfd8777b10717c95bd20e  libva-2.6.1.tar.bz2
 # Locally computed
-sha256 486bb6b5761db6e5a9f4475bd187e0bfa7309944cfc9734d496d41930353d6c5  libva-2.6.0.tar.bz2
+sha256 6c57eb642d828af2411aa38f55dc10111e8c98976dbab8fd62e48629401eaea5  libva-2.6.1.tar.bz2
 sha256 c86a782ee845b52472dae9b9d79fb915d333628ac0efe49cdce63644814931de  COPYING
index 0516cd0ab91ba413e08fcfd59441803690125300..5e9bedbbd5f1413121d32b70159148dc5bd92838 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBVA_VERSION = 2.6.0
+LIBVA_VERSION = 2.6.1
 LIBVA_SOURCE = libva-$(LIBVA_VERSION).tar.bz2
 LIBVA_SITE = https://github.com/intel/libva/releases/download/$(LIBVA_VERSION)
 LIBVA_LICENSE = MIT