Move creation of $(PROJECT_BUILD_DIR)/autotools-stamps into top level Makefile
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 5 Nov 2008 10:41:31 +0000 (10:41 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 5 Nov 2008 10:41:31 +0000 (10:41 -0000)
This patch will create the autotools-stamps directory early in the build
process, thus making it possible for non Makefile.autotools.in packages to use
this directory to hold stamp files.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Makefile
package/Makefile.autotools.in

index 5231bb6faf0af049650b745d2ebb84e782f077c2..2219f2b08eb3178c03a52882d47b9733e26e97c0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -318,6 +318,7 @@ endif
 
 $(PROJECT_BUILD_DIR)/.root:
        mkdir -p $(TARGET_DIR)
+       mkdir -p $(PROJECT_BUILD_DIR)/autotools-stamps
        if ! [ -d "$(TARGET_DIR)/bin" ]; then \
                if [ -d "$(TARGET_SKELETON)" ]; then \
                        cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
index 1a38d4ffbaf55bc4c0a7bf1990d434516eb45b72..6d62c047a5e5b5b1a7c02555aabf8e56f9e1130c 100644 (file)
@@ -258,7 +258,6 @@ $(PROJECT_BUILD_DIR)/autotools-stamps/%_target_installed:
        $(if $(BR2_HAVE_DOCUMENTATION),,for d in doc share/doc; do \
                rm -rf $(TARGET_DIR)/$$d $(TARGET_DIR)/usr/$$d; \
        done)
-       $(Q)mkdir -p $(@D)
        touch $@
 
 $(BUILD_DIR)/%/.stamp_cleaned: