open-plc-utils: fix build with static musl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 11 Oct 2018 18:20:13 +0000 (20:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 18:56:22 +0000 (20:56 +0200)
Pass TARGET_LDFLAGS to EXTRA_LDFLAGS to fix following issue:
/home/buildroot/autobuild/run/instance-3/output/build/host-gcc-final-7.3.0/build/arm-buildroot-linux-musleabihf/libgcc/../../../libgcc/config/arm/lib1funcs.S:1545: undefined reference to `raise'

Also pass TARGET_CFLAGS to EXTRA_CFLAGS and TARGET_CXXFLAGS to
EXTRA_CXXFLAGS and move all these variables to
OPEN_PLC_UTILS_MAKE_OPTS for readability

Fixes:
 - http://autobuild.buildroot.org/results/67bc5e7ac8ae1c49c035b022a394d2f746705cf2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/open-plc-utils/open-plc-utils.mk

index d45bb9d4f57f05da757a2fa74bc2cf2cbbea8a1e..e1e66bf7e0ff3ea3e66e81fb96ee4ccdd91c1f6e 100644 (file)
@@ -15,8 +15,14 @@ OPEN_PLC_UTILS_LICENSE_FILES = LICENSE
 # Yes, we're passing __UCLIBC__ in EXTRA_CFLAGS, as it fixes a build
 # issue for non-uClibc toolchains. It is the very crappy solution
 # suggested at https://github.com/qca/open-plc-utils/issues/36.
+OPEN_PLC_UTILS_MAKE_OPTS = \
+       EXTRA_CFLAGS="$(TARGET_CFLAGS) -D__UCLIBC__" \
+       EXTRA_CXXFLAGS="$(TARGET_CXXFLAGS)" \
+       EXTRA_LDFLAGS="$(TARGET_LDFLAGS)"
+
 define OPEN_PLC_UTILS_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) CROSS=$(TARGET_CROSS) EXTRA_CFLAGS="-D__UCLIBC__" -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE) CROSS=$(TARGET_CROSS) \
+               $(OPEN_PLC_UTILS_MAKE_OPTS) -C $(@D)
 endef
 
 define OPEN_PLC_UTILS_INSTALL_TARGET_CMDS