package/matchbox: drop useless dependencies
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:41 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 21:06:59 +0000 (23:06 +0200)
xlib-libXft is only needed when building a 'standalone' matchbox, which
means not using matchbox-lib.

But we *are* building matchbox-lib, and we do not support the standalone
mode (and probably won't, as even upstream says it is ugly, by lack of
theming).

Similarly, xlib-libXext is only used for its 'xsync' extension, for
which support is entirely commented-out in matchbox.

So, drop the dependency on xlib-libXft, and make it explicit we're not
building either standalone modes; drop xlib-libXext.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/Config.in
package/matchbox/matchbox.mk

index d42b90fbf7caa393a7ba0d4c9077d879ad78b9fe..0c7e5ea9f9133bec4a4aca3d452f7e4c25997ec8 100644 (file)
@@ -4,7 +4,6 @@ menuconfig BR2_PACKAGE_MATCHBOX
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_FONTCONFIG
        select BR2_PACKAGE_EXPAT
-       select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXCURSOR
        select BR2_PACKAGE_MATCHBOX_LIB
        help
index b1f96a6e5a223bf968c9837b54aea9cc67ac3c75..1abcfd8482fe93d6c73bf2ede3f51f5a9d7e1e97 100644 (file)
@@ -11,15 +11,16 @@ MATCHBOX_LICENSE = GPLv2+
 MATCHBOX_LICENSE_FILES = COPYING
 
 MATCHBOX_DEPENDENCIES = matchbox-lib
-MATCHBOX_CONF_OPTS = --enable-expat --disable-gconf --disable-composite
+MATCHBOX_CONF_OPTS = \
+       --enable-expat \
+       --disable-gconf \
+       --disable-composite \
+       --disable-standalone \
+       --disable-standalone-xft
 
 # Workaround bug in configure script
 MATCHBOX_CONF_ENV = expat=yes
 
-ifeq ($(BR2_PACKAGE_XLIB_LIBXFT),y)
-MATCHBOX_DEPENDENCIES += xlib_libXft
-endif
-
 ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
 MATCHBOX_CONF_OPTS += --enable-startup-notification
 MATCHBOX_DEPENDENCIES += startup-notification