package/erlang-p1-xmpp: bump to version 1.2.5
authorJohan Oudinet <johan.oudinet@gmail.com>
Mon, 26 Nov 2018 11:08:00 +0000 (12:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 28 Nov 2018 21:38:02 +0000 (22:38 +0100)
This package now depends also on erlang-p1-tls and erlang-p1-zlib.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/erlang-p1-xmpp/Config.in
package/erlang-p1-xmpp/erlang-p1-xmpp.hash
package/erlang-p1-xmpp/erlang-p1-xmpp.mk

index 9b33e0c609a5954647c9e45b3dd1b53d72e60a31..6e40fed10af6a00d39468980b492e48c64b37d99 100644 (file)
@@ -6,7 +6,9 @@ config BR2_PACKAGE_ERLANG_P1_XMPP
        depends on BR2_INSTALL_LIBSTDCPP # erlang-p1-stringprep
        select BR2_PACKAGE_ERLANG_P1_XML
        select BR2_PACKAGE_ERLANG_P1_STRINGPREP
+       select BR2_PACKAGE_ERLANG_P1_TLS
        select BR2_PACKAGE_ERLANG_P1_UTILS
+       select BR2_PACKAGE_ERLANG_P1_ZLIB
        help
          XMPP library for Erlang.
 
index d3d2dafb9ecd775e035fa7047f713799803b14f8..e1c63a6065a853c5835c347977ae85ba60dee896 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 558e8d8734052bdbe679cf10165a63944c208940ab84be78c97ba661dfcf3cb2 erlang-p1-xmpp-1.1.16.tar.gz
+sha256 699f50d50850272e67160b022fd27f3ccc46570e48968d8ee30d491bf926794d erlang-p1-xmpp-1.2.5.tar.gz
index 096876ca347130b40fe04845b03f5bf1c0a4bf9b..e20a84f4a3a8a04c4bf7eb21e7f023ef764ac8a1 100644 (file)
@@ -4,13 +4,13 @@
 #
 ################################################################################
 
-ERLANG_P1_XMPP_VERSION = 1.1.16
+ERLANG_P1_XMPP_VERSION = 1.2.5
 ERLANG_P1_XMPP_SITE = $(call github,processone,xmpp,$(ERLANG_P1_XMPP_VERSION))
 ERLANG_P1_XMPP_LICENSE = Apache-2.0
 ERLANG_P1_XMPP_LICENSE_FILES = LICENSE.txt
 ERLANG_P1_XMPP_INSTALL_STAGING = YES
 ERLANG_P1_XMPP_DEPENDENCIES = erlang-p1-xml erlang-p1-stringprep \
-       erlang-p1-utils host-erlang-p1-xml
+       erlang-p1-tls erlang-p1-utils erlang-p1-zlib host-erlang-p1-xml
 
 $(eval $(rebar-package))
 $(eval $(host-rebar-package))