package/libssh2: fix dependency on libgcrypt
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 8 Sep 2016 21:11:48 +0000 (23:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Sep 2016 20:49:04 +0000 (22:49 +0200)
Since 2f89476 (package/libgpg-error: bump to version 1.23), libssh2 has
inherited the dependency from libgcrypt (propagated from libgpg-error).

However, since libssh2 can use either openssl or libgcrypt as a backend,
the dependency should be relaxed when openssl is available.

But the test is broken and inverted: it will make libssh unavailable as
soon as openssl is enabled.

Fix this dependenc byt doing what other similar packages do: select
openssl if the other crypto backend (here libgcrypt) is not enabled.
This also allows us to drop the propagated dependency on the arch
condition.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Cc: Jörg Krause <joerg.krause@embedded.rocks>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Cc: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libssh2/Config.in
package/libssh2/libssh2.mk

index 0deb3bbcf18a7c643c96584f044987cfd6b50b7c..2944624e0a7564ab2e7a035dda3f75f19de0f38c 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_LIBSSH2
        bool "libssh2"
-       depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS && !BR2_PACKAGE_OPENSSL # libgcrypt
-       select BR2_PACKAGE_LIBGCRYPT if !BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_LIBGCRYPT
        help
          libssh2 is a client-side C library implementing the SSH2
          protocol as defined by Internet Drafts: SECSH-TRANS(22),
index 221fac473c677842fc7c120c1ddeb167ce3a0a84..847c2f1b8e530b6bbf80ad7338ea1469849dff24 100644 (file)
@@ -11,8 +11,8 @@ LIBSSH2_LICENSE_FILES = COPYING
 LIBSSH2_INSTALL_STAGING = YES
 LIBSSH2_CONF_OPTS = --disable-examples-build
 
-# libssh2 must use either libgcrypt or OpenSSL
-# Only select openssl if libgcrypt is not selected
+# Dependency is either on libgcrypt or openssl, guaranteed in Config.in.
+# Favour libgcrypt.
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 LIBSSH2_DEPENDENCIES += libgcrypt
 LIBSSH2_CONF_OPTS += --with-libgcrypt \