luajson: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:48 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:05:29 +0000 (16:05 +0100)
[Thomas: explicitly mention that lpeg is a run-time dependency, and
simplify the version specification. Both comments were made by
Arnout.]

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/luajson/Config.in [new file with mode: 0644]
package/luajson/luajson.mk [new file with mode: 0644]

index eb39b941aadfc4238d2c1c67e54595553db18811..cc44228208047decfb687fde64fade6e93433ec1 100644 (file)
@@ -384,6 +384,7 @@ source "package/luacrypto/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luaexpatutils/Config.in"
 source "package/luafilesystem/Config.in"
+source "package/luajson/Config.in"
 source "package/luaposix/Config.in"
 source "package/luasec/Config.in"
 source "package/luasocket/Config.in"
diff --git a/package/luajson/Config.in b/package/luajson/Config.in
new file mode 100644 (file)
index 0000000..c04aa7f
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LUAJSON
+       bool "luajson"
+       # run-time dependency
+       select BR2_PACKAGE_LPEG
+       help
+         LuaJSON is a customizable JSON decoder/encoder
+         using LPEG for parsing.
+
+         http://github.com/harningt/luajson
diff --git a/package/luajson/luajson.mk b/package/luajson/luajson.mk
new file mode 100644 (file)
index 0000000..3a4f81d
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# luajson
+#
+################################################################################
+
+LUAJSON_VERSION = 1.3.2-1
+LUAJSON_SUBDIR  = luajson
+LUAJSON_LICENSE = MIT
+LUAJSON_LICENSE_FILES = $(LUAJSON_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))