libeXosip2: fix openssl handling
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Dec 2011 16:19:01 +0000 (17:19 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Dec 2011 20:13:58 +0000 (21:13 +0100)
Build libeXosip2 after openssl if enabled, and explicitly disable support
for it otherwise, so configure doesn't end up looking for it on host.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libeXosip2/libeXosip2.mk

index 4a00a2b2f1097dd10f9e3e09d619655f1c6d8824..7c4753df3346ad4abeb595c169e26545ef4baba8 100644 (file)
@@ -11,6 +11,13 @@ LIBEXOSIP2_INSTALL_STAGING = YES
 
 LIBEXOSIP2_DEPENDENCIES = host-pkg-config libosip2
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBEXOSIP2_DEPENDENCIES += openssl
+LIBEXOSIP2_CONF_OPT += --enable-openssl
+else
+LIBEXOSIP2_CONF_OPT += --disable-openssl
+endif
+
 ifneq ($(LIBEXOSIP2_PATCH),)
 define LIBEXOSIP2_DEBIAN_PATCHES
        if [ -d $(@D)/debian/patches ]; then \