package/{clang,lld}: disable shared lib build for the host variant
authorMichael Nosthoff <buildroot@heine.tech>
Wed, 16 Sep 2020 10:02:10 +0000 (12:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 17 Sep 2020 20:32:23 +0000 (22:32 +0200)
This is similar to the llvm package which also disables shared libs
for the host variant.

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/clang/clang.mk
package/lld/lld.mk

index d740af5322186d55bb29307502228389ba78eded..ceb7de9afaa560b26840ce1972f4f51529256d2b 100644 (file)
@@ -33,6 +33,7 @@ CLANG_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
 # By setting BUILD_SHARED_LIBS to OFF, we generate multiple static
 # libraries (the same way as host's clang build) and finally
 # libclang.so to be installed on the target.
+HOST_CLANG_CONF_OPTS += -DBUILD_SHARED_LIBS=OFF
 CLANG_CONF_OPTS += -DBUILD_SHARED_LIBS=OFF
 
 # Default is Debug build, which requires considerably more disk space
index ea09c5d340e904e4af4c506b413e276b77adb5d1..cd1a03c1d3286d26c87f01df9a9cc0c584f8118f 100644 (file)
@@ -19,6 +19,9 @@ HOST_LLD_DEPENDENCIES = host-llvm
 # https://reviews.llvm.org/D57264
 HOST_LLD_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
 
+# build as static libs as is done in llvm & clang
+HOST_LLD_CONF_OPTS += -DBUILD_SHARED_LIBS=OFF
+
 # GCC looks for tools in a different path from LLD's default installation path
 define HOST_LLD_CREATE_SYMLINKS
        mkdir -p $(HOST_DIR)/$(GNU_TARGET_NAME)/bin