linux: rename config option
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 7 Jun 2020 07:21:12 +0000 (09:21 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 7 Jun 2020 07:27:08 +0000 (09:27 +0200)
Commit a4eef9a3959 (linux: introduce BR2_KERNEL_DTB_KEEP_DIRNAME)
introduced a new config option, but its name was not matching the
naming-scheme of the other config options.

Rename it.

We don't need legacy handling, because that config option was added very
recently and was never part of a release.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
linux/Config.in
linux/linux.mk

index 61e84f00b4e0bf596438669cbc0012b684e7bd29..2af3a00352c0a1aaa83e1673a70d105ae5ecc454 100644 (file)
@@ -407,7 +407,7 @@ config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
          You can provide a list of dts paths to copy and
          build, separated by spaces.
 
-config BR2_KERNEL_DTB_KEEP_DIRNAME
+config BR2_LINUX_KERNEL_DTB_KEEP_DIRNAME
        bool "Keep the directory name of the Device Tree"
        help
          If enabled, the device tree blobs keep their
index c3859a59d57eeca891107f8c71e8ddff6fe55654..b90b032bb90936de89de1bd82e7a35337cf43700 100644 (file)
@@ -381,7 +381,7 @@ define LINUX_INSTALL_DTB
        $(foreach dtb,$(LINUX_DTBS), \
                install -D \
                        $(or $(wildcard $(LINUX_ARCH_PATH)/boot/dts/$(dtb)),$(LINUX_ARCH_PATH)/boot/$(dtb)) \
-                       $(1)/$(if $(BR2_KERNEL_DTB_KEEP_DIRNAME),$(dtb),$(notdir $(dtb)))
+                       $(1)/$(if $(BR2_LINUX_KERNEL_DTB_KEEP_DIRNAME),$(dtb),$(notdir $(dtb)))
        )
 endef
 endif # BR2_LINUX_KERNEL_APPENDED_DTB