Merge branch 'next'
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Sep 2019 13:03:02 +0000 (15:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Sep 2019 13:03:02 +0000 (15:03 +0200)
1  2 
.gitlab-ci.yml
Config.in.legacy
DEVELOPERS
Makefile
docs/manual/common-usage.txt
package/Config.in
package/autofs/autofs.mk
package/gcc/Config.in.host
package/gnutls/gnutls.mk

diff --cc .gitlab-ci.yml
index 5d42d2a606212ec1fae5ccee884f0f65c006d579,99940640a535f74a46ae982750e586ab51d19b0f..6243107ee9cf5fdef9177a69384faf1056c50ead
@@@ -312,7 -317,9 +312,8 @@@ solidrun_macchiatobin_mainline_defconfi
  solidrun_macchiatobin_marvell_defconfig: { extends: .defconfig }
  stm32f429_disco_defconfig: { extends: .defconfig }
  stm32f469_disco_defconfig: { extends: .defconfig }
+ stm32mp157_dk_defconfig: { extends: .defconfig }
  toradex_apalis_imx6_defconfig: { extends: .defconfig }
 -ts4800_defconfig: { extends: .defconfig }
  ts4900_defconfig: { extends: .defconfig }
  ts5500_defconfig: { extends: .defconfig }
  ts7680_defconfig: { extends: .defconfig }
index 83dce8b3c8e54242927af6afffbd190ba9e8b0de,ac3697b870de07fd4433edce66a0de9fdd05d8cb..72c364ecb54aa7753ee6c7998adbdc635a98f1dc
@@@ -144,44 -144,23 +144,59 @@@ endi
  
  ###############################################################################
  
+ comment "Legacy options removed in 2019.11"
+ config BR2_PACKAGE_WPA_SUPPLICANT_DBUS_NEW
+       bool "new dbus support option in wpa_supplicant was renamed"
+       select BR2_PACKAGE_WPA_SUPPLICANT_DBUS if BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_LEGACY
+       help
+         The new dbus support option was renamed.
+ config BR2_PACKAGE_WPA_SUPPLICANT_DBUS_OLD
+       bool "old dbus support in wpa_supplicant was removed"
+       select BR2_LEGACY
+       help
+         The old dbus support was removed.
  comment "Legacy options removed in 2019.08"
  
 +config BR2_TARGET_TS4800_MBRBOOT
 +      bool "ts4800-mbrboot package was removed"
 +      select BR2_LEGACY
 +      help
 +        The defconfig for the TS4800 platform has been removed, so
 +        the ts4800-mbrboot package, containing the boot code for
 +        this specific platform has been removed as welL.
 +
 +config BR2_PACKAGE_LIBAMCODEC
 +      bool "liamcodec package was removed"
 +      select BR2_LEGACY
 +      help
 +        Support for odroidc2 based systems was removed, making the
 +        libamcodec package useless.
 +
 +config BR2_PACKAGE_ODROID_SCRIPTS
 +      bool "odroid-scripts package was removed"
 +      select BR2_LEGACY
 +      help
 +        Support for odroidc2 based systems was removed, making the
 +        odroid-scripts package useless.
 +
 +config BR2_PACKAGE_ODROID_MALI
 +      bool "odroid-mali package was removed"
 +      select BR2_LEGACY
 +      help
 +        Support for odroidc2 based systems was removed, making the
 +        odroid-mali package useless.
 +
 +config BR2_PACKAGE_KODI_PLATFORM_AML
 +      bool "Kodi AMLogic support was removed"
 +      select BR2_LEGACY
 +      help
 +        Support for AMLogic was removed due to the removal of the
 +        odroidc2 defconfig.
 +
  config BR2_GCC_VERSION_6_X
        bool "gcc 6.x support removed"
        select BR2_LEGACY
diff --cc DEVELOPERS
Simple merge
diff --cc Makefile
Simple merge
index a36301afd5071fd9581de1fd4a0b52f4713528de,d9f086234cc32d905dbbc1cda429df310eb8edf6..a87980d4a2b7a66be4504fcd1eff4d223c52755a
@@@ -310,10 -313,25 +313,25 @@@ installed (+python-matplotlib+ on most 
  +argparse+ module if you're using a Python version older than 2.7
  (+python-argparse+ on most distributions).
  
 -Just like for the duration graph, a +BR2_GRAPH_OUT+ environment is
 -supported to adjust the output file format. See xref:graph-depends[]
 +Just like for the duration graph, a +BR2_GRAPH_OUT+ environment variable
 +is supported to adjust the output file format. See xref:graph-depends[]
  for details about this environment variable.
  
+ Additionally, one may set the environment variable +BR2_GRAPH_SIZE_OPTS+
+ to further control the generated graph. Accepted options are:
+ * `--size-limit X`, `-l X`, will group all packages which individual
+   contribution is below `X` percent, to a single entry labelled _Others_
+   in the graph. By default, `X=0.01`, which means packages each
+   contributing less than 1% are grouped under _Others_. Accepted values
+   are in the range `[0.0..1.0]`.
+ * `--iec`, `--binary`, `--si`, `--decimal`, to use IEC (binary, powers
+   of 1024) or SI (decimal, powers of 1000; the default) prefixes.
+ * `--biggest-first`, to sort packages in decreasing size order, rather
+   than in increasing size order.
  .Note
  The collected filesystem size data is only meaningful after a complete
  clean rebuild. Be sure to run +make clean all+ before using +make
index 710ed12be03eae596ef5d6556636e16093329ab6,9f544f955c7aada492eb70966578139ea44241e1..9336261c5d9e14ebbf04d056c77633060f937c7b
@@@ -1502,8 -1505,10 +1503,9 @@@ endmen
  
  menu "Multimedia"
        source "package/bitstream/Config.in"
+       source "package/dav1d/Config.in"
        source "package/kvazaar/Config.in"
        source "package/libaacs/Config.in"
 -      source "package/libamcodec/Config.in"
        source "package/libass/Config.in"
        source "package/libbdplus/Config.in"
        source "package/libbluray/Config.in"
Simple merge
Simple merge
index 700737050d9ada53556096999ef3ed8a43b0cf74,ecbedec5c8edb991abfeaa029dc514be9986dff5..94935a3f9e32fc6dce84940f19001740bf2a77d7
@@@ -5,17 -5,11 +5,17 @@@
  ################################################################################
  
  GNUTLS_VERSION_MAJOR = 3.6
- GNUTLS_VERSION = $(GNUTLS_VERSION_MAJOR).8
+ GNUTLS_VERSION = $(GNUTLS_VERSION_MAJOR).9
  GNUTLS_SOURCE = gnutls-$(GNUTLS_VERSION).tar.xz
  GNUTLS_SITE = https://www.gnupg.org/ftp/gcrypt/gnutls/v$(GNUTLS_VERSION_MAJOR)
 -GNUTLS_LICENSE = LGPL-2.1+ (core library), GPL-3.0+ (gnutls-openssl library)
 -GNUTLS_LICENSE_FILES = doc/COPYING doc/COPYING.LESSER
 +GNUTLS_LICENSE = LGPL-2.1+ (core library)
 +GNUTLS_LICENSE_FILES = doc/COPYING.LESSER
 +
 +ifeq ($(BR2_PACKAGE_GNUTLS_OPENSSL),y)
 +GNUTLS_LICENSE := $(GNUTLS_LICENSE), GPL-3.0+ (gnutls-openssl library)
 +GNUTLS_LICENSE_FILES += doc/COPYING
 +endif
 +
  GNUTLS_DEPENDENCIES = host-pkgconf libtasn1 nettle pcre
  GNUTLS_CONF_OPTS = \
        --disable-doc \