package/botan: bump to version 2.18.1
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 12 Sep 2021 19:48:15 +0000 (21:48 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Sep 2021 20:38:34 +0000 (22:38 +0200)
Drop patches (already in version)

https://github.com/randombit/botan/blob/2.18.1/news.rst

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/botan/0001-Add--extra-libs-option-and-group-l-flags-from-LDFLAGS-to-the-end.patch [deleted file]
package/botan/0002-Avoid-empty-l.patch [deleted file]
package/botan/0003-Add-support-for-riscv32.patch [deleted file]
package/botan/botan.hash
package/botan/botan.mk

diff --git a/package/botan/0001-Add--extra-libs-option-and-group-l-flags-from-LDFLAGS-to-the-end.patch b/package/botan/0001-Add--extra-libs-option-and-group-l-flags-from-LDFLAGS-to-the-end.patch
deleted file mode 100644 (file)
index 8aa5c68..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From af63fe89228172e5a395f7e6491fae3bfa9da4b1 Mon Sep 17 00:00:00 2001
-From: Jack Lloyd <jack@randombit.net>
-Date: Mon, 15 Feb 2021 15:01:38 -0500
-Subject: [PATCH] Add --extra-libs option and group -l flags from LDFLAGS to
- the end
-
-Ref #2622
-
-[Retrieved from:
-https://github.com/randombit/botan/commit/af63fe89228172e5a395f7e6491fae3bfa9da4b1]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- configure.py               | 14 ++++++++++++++
- src/build-data/makefile.in |  2 +-
- 2 files changed, 15 insertions(+), 1 deletion(-)
-
-diff --git a/configure.py b/configure.py
-index 73fc0271e9..865a6c8e62 100755
---- a/configure.py
-+++ b/configure.py
-@@ -333,6 +333,9 @@ def process_command_line(args): # pylint: disable=too-many-locals,too-many-state
-     target_group.add_option('--ldflags', metavar='FLAGS',
-                             help='set linker flags', default=None)
-+    target_group.add_option('--extra-libs', metavar='LIBS',
-+                            help='specify extra libraries to link against', default='')
-+
-     target_group.add_option('--ar-command', dest='ar_command', metavar='AR', default=None,
-                             help='set path to static archive creator')
-@@ -2020,6 +2023,12 @@ def choose_cxx_exe():
-         else:
-             return '%s %s' % (options.compiler_cache, cxx)
-+    def extra_libs(libs, cc):
-+        if libs is None:
-+            return ''
-+
-+        return ' '.join([(cc.add_lib_option % lib) for lib in libs.split(',')])
-+
-     variables = {
-         'version_major':  Version.major(),
-         'version_minor':  Version.minor(),
-@@ -2149,6 +2158,7 @@ def choose_cxx_exe():
-         'cc_sysroot': sysroot_option(),
-         'cc_compile_flags': options.cxxflags or cc.cc_compile_flags(options),
-         'ldflags': options.ldflags or '',
-+        'extra_libs': extra_libs(options.extra_libs, cc),
-         'cc_warning_flags': cc.cc_warning_flags(options),
-         'output_to_exe': cc.output_to_exe,
-         'cc_macro': cc.macro_name,
-@@ -3029,6 +3039,10 @@ def canonicalize_build_targets(options):
-     if options.build_fuzzers == 'libfuzzer' and options.fuzzer_lib is None:
-         options.fuzzer_lib = 'Fuzzer'
-+    if options.ldflags is not None:
-+        libs = [m.group(1) for m in re.finditer(r'-l([a-z0-9]+)', options.ldflags)]
-+        options.extra_libs += ','.join(libs)
-+
- # Checks user options for consistency
- # This method DOES NOT change options on behalf of the user but explains
- # why the given configuration does not work.
-diff --git a/src/build-data/makefile.in b/src/build-data/makefile.in
-index 4692d00f71..82f6576650 100644
---- a/src/build-data/makefile.in
-+++ b/src/build-data/makefile.in
-@@ -20,7 +20,7 @@ LDFLAGS        = %{ldflags}
- EXE_LINK_CMD   = %{exe_link_cmd}
- LIB_LINKS_TO   = %{external_link_cmd} %{link_to}
--EXE_LINKS_TO   = %{link_to_botan} $(LIB_LINKS_TO)
-+EXE_LINKS_TO   = %{link_to_botan} $(LIB_LINKS_TO) %{extra_libs}
- BUILD_FLAGS    = $(ABI_FLAGS) $(LANG_FLAGS) $(CXXFLAGS) $(WARN_FLAGS)
diff --git a/package/botan/0002-Avoid-empty-l.patch b/package/botan/0002-Avoid-empty-l.patch
deleted file mode 100644 (file)
index 9102360..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4b2225ea54988e09b649768848b3c14b43e064de Mon Sep 17 00:00:00 2001
-From: Jack Lloyd <jack@randombit.net>
-Date: Mon, 15 Feb 2021 15:11:12 -0500
-Subject: [PATCH] Avoid empty -l
-
-[Retrieved from:
-https://github.com/randombit/botan/commit/4b2225ea54988e09b649768848b3c14b43e064de]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- configure.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.py b/configure.py
-index 865a6c8e62..a79f672eca 100755
---- a/configure.py
-+++ b/configure.py
-@@ -2027,7 +2027,7 @@ def extra_libs(libs, cc):
-         if libs is None:
-             return ''
--        return ' '.join([(cc.add_lib_option % lib) for lib in libs.split(',')])
-+        return ' '.join([(cc.add_lib_option % lib) for lib in libs.split(',') if lib != ''])
-     variables = {
-         'version_major':  Version.major(),
diff --git a/package/botan/0003-Add-support-for-riscv32.patch b/package/botan/0003-Add-support-for-riscv32.patch
deleted file mode 100644 (file)
index d8978b2..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 443bf46ee2b1b1d7acd63e3f00dcbe66646138f8 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Fri, 2 Apr 2021 20:37:03 +0200
-Subject: [PATCH] Add support for riscv32
-
-Fix the following build failure:
-
-  ERROR: Unknown or unidentifiable processor "riscv32"
-
-Fixes:
- - http://autobuild.buildroot.org/results/1c399312dbec5d7a28ec90d62fdd8f47fa14ff4b
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Retrieved from:
-https://github.com/randombit/botan/commit/aa7958880bee2091a8a71bf9e1f6e6efb34581e3]
----
- src/build-data/arch/riscv32.txt | 2 ++
- 1 file changed, 2 insertions(+)
- create mode 100644 src/build-data/arch/riscv32.txt
-
-diff --git a/src/build-data/arch/riscv32.txt b/src/build-data/arch/riscv32.txt
-new file mode 100644
-index 000000000..ba88b42e9
---- /dev/null
-+++ b/src/build-data/arch/riscv32.txt
-@@ -0,0 +1,2 @@
-+family riscv32
-+endian little
--- 
-2.30.2
-
index d1b1d14acb6b68c6cec3e37e5aef74d30880d0d6..b7804ce9d7c7fd3c2c25ae06903abb7eb895faee 100644 (file)
@@ -1,4 +1,4 @@
 # From https://botan.randombit.net/releases/sha256sums.txt
-sha256  79123b654445a4abba486e09a431788545c708237382a3e765664c9f55b03b88  Botan-2.17.3.tar.xz
+sha256  f8c7b46222a857168a754a5cc329bb780504122b270018dda5304c98db28ae29  Botan-2.18.1.tar.xz
 # Locally computed
 sha256  fb7f0322d36fba55ca17d77bc203a9f09a40daa8a249b75cf8887aba36cec9d0  license.txt
index 2e3f99b49bb8b9f4dec97770d7af96a1cb5f00ca..c23aba99dddb7e459d704792108f304d3abb9e90 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BOTAN_VERSION = 2.17.3
+BOTAN_VERSION = 2.18.1
 BOTAN_SOURCE = Botan-$(BOTAN_VERSION).tar.xz
 BOTAN_SITE = http://botan.randombit.net/releases
 BOTAN_LICENSE = BSD-2-Clause