toolchain/crosstool-NG: fix sysroot name
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Tue, 19 Apr 2011 21:02:21 +0000 (23:02 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 20 Apr 2011 13:13:09 +0000 (15:13 +0200)
We have to ensure that the sysroot created while building the
toolchain will be the one we later search for libraries. So:
 - hide the sysroot name prompt from the ct-ng menu.
 - force the sysroot name to be 'sysroot'.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-crosstool-ng/002-no-sysroot-prompt-in-backend.patch [new file with mode: 0644]
toolchain/toolchain-crosstool-ng/crosstool-ng.mk

diff --git a/toolchain/toolchain-crosstool-ng/002-no-sysroot-prompt-in-backend.patch b/toolchain/toolchain-crosstool-ng/002-no-sysroot-prompt-in-backend.patch
new file mode 100644 (file)
index 0000000..4c3426a
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/config/toolchain.in b/config/toolchain.in
+--- a/config/toolchain.in
++++ b/config/toolchain.in
+@@ -20,7 +20,7 @@
+ config SYSROOT_NAME
+     string
+-    prompt "sysroot directory name"
++    prompt "sysroot directory name" if ! BACKEND
+     depends on USE_SYSROOT
+     default "sysroot"
+     help
index 2c5829cb2dc5ec8f7761fa0f72b811b443ecbeb9..c57876e48a1ebbdf2d1c994909196b0e4e18cad1 100644 (file)
@@ -257,6 +257,7 @@ endif
 # And the specials for paths
 CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_PREFIX_DIR)=.*:\1="$(HOST_DIR)/usr":;
 CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LOCAL_TARBALLS_DIR)=.*:\1="$(DL_DIR)":;
+CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_SYSROOT_NAME)=.*:\1="sysroot":;
 CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_SYSROOT_DIR_PREFIX)=.*:\1="":;
 
 #--------------