package/collectd: add onewire support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 10 Jun 2019 15:45:29 +0000 (17:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 28 Oct 2019 12:59:21 +0000 (13:59 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/collectd/Config.in
package/collectd/collectd.mk

index bda546e67e32a9d1ca4d5f34ebb7171d626d12e6..4fa4074a5135ad2f257dbfec3e61bd2a6a171a18 100644 (file)
@@ -359,6 +359,13 @@ config BR2_PACKAGE_COLLECTD_OLSRD
        help
          Reads information about meshed networks from olsrd.
 
+config BR2_PACKAGE_COLLECTD_ONEWIRE
+       bool "onewire"
+       select BR2_PACKAGE_OWFS
+       help
+         Collects temperature information from sensors connected over
+         the OneWire bus.
+
 config BR2_PACKAGE_COLLECTD_OPENLDAP
        bool "openldap"
        depends on BR2_USE_WCHAR
index fefd5641b2fcec34f2758843736312936093418f..31f7340d98cbe53c970ced7fea42238c903d0e74 100644 (file)
@@ -20,7 +20,7 @@ COLLECTD_PLUGINS_DISABLE = \
        apple_sensors aquaero ascent barometer dbi dpdkstat email \
        gmond hddtemp intel_rdt ipmi java lpar lua lvm \
        madwifi mbmon mic multimeter netapp notify_desktop numa \
-       nut onewire oracle perl pf pinba powerdns python routeros \
+       nut oracle perl pf pinba powerdns python routeros \
        rrdcached sigrok tape target_v5upgrade teamspeak2 ted \
        tokyotyrant turbostat uuid varnish virt vserver write_kafka \
        write_mongodb xencpu xmms zfs_arc zone
@@ -105,6 +105,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_NOTIFY_NAGIOS),--enable-notify_nagios,--disable-notify_nagios) \
        $(if $(BR2_PACKAGE_COLLECTD_NTPD),--enable-ntpd,--disable-ntpd) \
        $(if $(BR2_PACKAGE_COLLECTD_OLSRD),--enable-olsrd,--disable-olsrd) \
+       $(if $(BR2_PACKAGE_COLLECTD_ONEWIRE),--enable-onewire,--disable-onewire) \
        $(if $(BR2_PACKAGE_COLLECTD_OPENLDAP),--enable-openldap,--disable-openldap) \
        $(if $(BR2_PACKAGE_COLLECTD_OPENVPN),--enable-openvpn,--disable-openvpn) \
        $(if $(BR2_PACKAGE_COLLECTD_PING),--enable-ping,--disable-ping) \
@@ -167,6 +168,7 @@ COLLECTD_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_COLLECTD_NETLINK),libmnl) \
        $(if $(BR2_PACKAGE_COLLECTD_NGINX),libcurl) \
        $(if $(BR2_PACKAGE_COLLECTD_NOTIFY_EMAIL),libesmtp) \
+       $(if $(BR2_PACKAGE_COLLECTD_ONEWIRE),owfs) \
        $(if $(BR2_PACKAGE_COLLECTD_OPENLDAP),openldap) \
        $(if $(BR2_PACKAGE_COLLECTD_PING),liboping) \
        $(if $(BR2_PACKAGE_COLLECTD_POSTGRESQL),postgresql) \