fs/tar: make --no-recursion effective
authorBaruch Siach <baruch@tkos.co.il>
Tue, 27 Dec 2016 17:42:03 +0000 (19:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 28 Dec 2016 09:13:21 +0000 (10:13 +0100)
The tar --no-recursion option is position sensitive. It only affects following
file listing options. Move --no-recursion before the -T option to make it
effective. This fixes duplication of entries in the generated rootfs.tar
archive.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/tar/tar.mk

index b14c977d761c5c0d638c8c01d0e84c4b4b61ec8f..0e3eacbedf05db615d39628a02ecc095e1a55317 100644 (file)
@@ -8,7 +8,7 @@ TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
 
 define ROOTFS_TAR_CMD
        (cd $(TARGET_DIR); find -print0 | LC_ALL=C sort -z | \
-               tar $(TAR_OPTS) -cf $@ --null -T - --no-recursion --numeric-owner)
+               tar $(TAR_OPTS) -cf $@ --null --no-recursion -T - --numeric-owner)
 endef
 
 $(eval $(call ROOTFS_TARGET,tar))