package/sslh: add optional systemd dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 24 May 2019 15:11:22 +0000 (17:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 May 2019 13:39:39 +0000 (15:39 +0200)
systemd dependency has been added in version 1.18 with
https://github.com/yrutschle/sslh/commit/b3f48d98767634007dbe29ee3cb609a2e4283b7d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sslh/sslh.mk

index d0a5f82347c4d08a07db15d02a39e47b7d4c8ace..6e29a99189f866cdc833edff1da58f3862898c0a 100644 (file)
@@ -27,6 +27,13 @@ else
 SSLH_MAKE_OPTS += USELIBPCRE=
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+SSLH_DEPENDENCIES += systemd
+SSLH_MAKE_OPTS += USESYSTEMD=1
+else
+SSLH_MAKE_OPTS += USESYSTEMD=
+endif
+
 define SSLH_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(SSLH_MAKE_OPTS) -C $(@D)
 endef