add more recent version of freetype, required at least for avr32 to build correctly
authorIvan Kuten <ivan.kuten@promwad.com>
Fri, 16 Nov 2007 10:16:48 +0000 (10:16 -0000)
committerIvan Kuten <ivan.kuten@promwad.com>
Fri, 16 Nov 2007 10:16:48 +0000 (10:16 -0000)
package/freetype/Config.in
package/freetype/freetype.mk

index f3ce268e0c577f768f38e6c1d66e0d055f686861..515dd151111c59f415fe4cb5e2f884e5ab216bd6 100644 (file)
@@ -4,3 +4,23 @@ config BR2_PACKAGE_FREETYPE
        help
 
        http://www.freetype.org/
+
+choice
+       prompt "Freetype Version"
+       depends BR2_PACKAGE_FREETYPE
+       default BR2_FREETYPE_VERSION_2_2_1
+       help
+         Select the version of Freetype you wish to use.
+
+       config BR2_FREETYPE_VERSION_2_2_1
+               bool "Freetype 2.2.1"
+
+       config BR2_FREETYPE_VERSION_2_3_5
+               bool "Freetype 2.3.5"
+
+endchoice
+
+config BR2_FREETYPE_VERSION
+       string
+       default "2.2.1"         if BR2_FREETYPE_VERSION_2_2_1
+       default "2.3.5"         if BR2_FREETYPE_VERSION_2_3_5
index 1c98fd199bc4f3eed4af69613855bf6307bb17d5..e7e8666becd6b1e4e1489e17aa841de3c5650e22 100644 (file)
@@ -3,7 +3,7 @@
 # freetype
 #
 #############################################################
-FREETYPE_VERSION:=2.2.1
+FREETYPE_VERSION:=$(strip $(subst ",, $(BR2_FREETYPE_VERSION)))
 FREETYPE_SOURCE:=freetype-$(FREETYPE_VERSION).tar.bz2
 FREETYPE_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/freetype
 FREETYPE_CAT:=$(BZCAT)