package/python{,3}-regex: bump to version 2021.4.4
authorLeon Anavi <leon.anavi@konsulko.com>
Fri, 9 Apr 2021 09:00:56 +0000 (12:00 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 22 Apr 2021 19:51:55 +0000 (21:51 +0200)
Upgrade to release 2021.4.4 with the following bug fixes:

- regex fails with a quantified backreference but succeeds with
  repeated backref
- API is not a drop-in replacement for python's re when it comes
  to typing

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-regex/python-regex.hash
package/python-regex/python-regex.mk
package/python3-regex/python3-regex.mk

index 9e256263a97bf85d394cfab2c4524aecf49924a7..4749cd61674eaa9f130621b8654c9fb4f00f377a 100644 (file)
@@ -1,3 +1,3 @@
 # md5, sha256 from https://pypi.org/pypi/regex/json
-md5  ac88a9c036e626ae4d436e69f35f50cf  regex-2020.2.20.tar.gz
-sha256  9e9624440d754733eddbcd4614378c18713d2d9d0dc647cf9c72f64e39671be5  regex-2020.2.20.tar.gz
+md5  cd206281327b4c087bb20bf93cee4ab9  regex-2021.4.4.tar.gz
+sha256  52ba3d3f9b942c49d7e4bc105bb28551c44065f139a65062ab7912bef10c9afb  regex-2021.4.4.tar.gz
index 8a527c8ee76149046bfad80a78d00b31039b9c03..c46c4d1614a045d3d1c0d36a38e9a5aab46303aa 100644 (file)
@@ -5,9 +5,9 @@
 ################################################################################
 
 # Please keep in sync with package/python3-regex/python3-regex.mk
-PYTHON_REGEX_VERSION = 2020.2.20
+PYTHON_REGEX_VERSION = 2021.4.4
 PYTHON_REGEX_SOURCE = regex-$(PYTHON_REGEX_VERSION).tar.gz
-PYTHON_REGEX_SITE = https://files.pythonhosted.org/packages/e8/76/8ac7f467617b9cfbafcef3c76df6f22b15de654a62bea719792b00a83195
+PYTHON_REGEX_SITE = https://files.pythonhosted.org/packages/38/3f/4c42a98c9ad7d08c16e7d23b2194a0e4f3b2914662da8bc88986e4e6de1f
 PYTHON_REGEX_SETUP_TYPE = setuptools
 PYTHON_REGEX_LICENSE = CNRI-Python
 
index f75fb76ace7fbc012b96ce3525b7be676df35995..0b71768e9dbd793e5d1e774af5234bd297990722 100644 (file)
@@ -5,9 +5,9 @@
 ################################################################################
 
 # Please keep in sync with package/python-regex/python-regex.mk
-PYTHON3_REGEX_VERSION = 2020.2.20
+PYTHON3_REGEX_VERSION = 2021.4.4
 PYTHON3_REGEX_SOURCE = regex-$(PYTHON3_REGEX_VERSION).tar.gz
-PYTHON3_REGEX_SITE = https://files.pythonhosted.org/packages/e8/76/8ac7f467617b9cfbafcef3c76df6f22b15de654a62bea719792b00a83195
+PYTHON3_REGEX_SITE = https://files.pythonhosted.org/packages/38/3f/4c42a98c9ad7d08c16e7d23b2194a0e4f3b2914662da8bc88986e4e6de1f
 PYTHON3_REGEX_SETUP_TYPE = setuptools
 PYTHON3_REGEX_LICENSE = CNRI-Python
 HOST_PYTHON3_REGEX_DL_SUBDIR = python-regex