execline: restore --shebangdir configure option
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Fri, 7 Jul 2017 17:09:46 +0000 (19:09 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Jul 2017 11:44:05 +0000 (13:44 +0200)
Passing the option --shebangdir=/usr/bin to the configuration script adds the
CPP definition EXECLINE_SHEBANGPREFIX to
execline-x.y.z/src/include/execline/config.h. It is used by `s6-rc-compile` from
the s6-rc package to set the path to the execline interpreter in the scripts it
generates.

So, when building the host variant of execline, this path will be used in the
target service scripts generated by the host variant of `s6-rc-compile`. If not
forced to /usr/bin, the location of the execline interpreter on the target, it
will default to $(HOST_DIR)/bin thus leading to non-working scripts on the
target.

So, restore this option for the host variant.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/execline/execline.mk

index d3d69a85d97ce43ecbafc1740504eb6e211dcfa9..576f11c243f4f06326464eb8b4536b696dd9a534 100644 (file)
@@ -44,8 +44,11 @@ endef
 
 HOST_EXECLINE_DEPENDENCIES = host-skalibs
 
+# Set --shebangdir to /usr/bin, as this value is used by the host variant of
+# s6-rc when generating execline scripts for the target.
 HOST_EXECLINE_CONF_OPTS = \
        --prefix=$(HOST_DIR) \
+       --shebangdir=/usr/bin \
        --with-sysdeps=$(HOST_DIR)/lib/skalibs/sysdeps \
        --with-include=$(HOST_DIR)/include \
        --with-dynlib=$(HOST_DIR)/lib \