mpir: new package
authorSemyon Kolganov <semenak94@mail.ru>
Thu, 13 Apr 2017 20:32:01 +0000 (23:32 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Apr 2017 21:04:15 +0000 (23:04 +0200)
Signed-off-by: Semyon Kolganov <semenak94@mail.ru>
[Thomas:
 - rewrap Config.in help text
 - add missing host-yasm dependency
 - remove custom MPIR_MAKE_OPTS, apparently not needed]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/mpir/Config.in [new file with mode: 0644]
package/mpir/mpir.hash [new file with mode: 0644]
package/mpir/mpir.mk [new file with mode: 0644]

index 83cf6307fb8b2d3aeb09d241f1a3115d7034c6b0..aa1bc56605dfffca40317d09bb2f9c69937f6a6a 100644 (file)
@@ -1422,6 +1422,7 @@ F:        package/yaml-cpp/
 N:     Semyon Kolganov <semenak94@mail.ru>
 F:     package/fmt/
 F:     package/libbson/
+F:     package/mpir/
 
 N:     Sergio Prado <sergio.prado@e-labworks.com>
 F:     package/libgdiplus/
index 9a8158922774c7469b5661d11c32919357f81dce..a5e48ace0e2a4a2ee00de13618b4ae24b6fa81ef 100644 (file)
@@ -1407,6 +1407,7 @@ endif
        source "package/mpc/Config.in"
        source "package/mpdecimal/Config.in"
        source "package/mpfr/Config.in"
+       source "package/mpir/Config.in"
        source "package/msgpack/Config.in"
        source "package/mtdev2tuio/Config.in"
        source "package/musl-compat-headers/Config.in"
diff --git a/package/mpir/Config.in b/package/mpir/Config.in
new file mode 100644 (file)
index 0000000..da4cc9f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_MPIR
+       bool "mpir"
+       select BR2_PACKAGE_GMP
+       help
+         MPIR is a highly optimised library for bignum arithmetic
+         forked from the GMP bignum library.
+
+         http://www.mpir.org/
diff --git a/package/mpir/mpir.hash b/package/mpir/mpir.hash
new file mode 100644 (file)
index 0000000..8320337
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 52f63459cf3f9478859de29e00357f004050ead70b45913f2c2269d9708675bb        mpir-3.0.0.tar.bz2
diff --git a/package/mpir/mpir.mk b/package/mpir/mpir.mk
new file mode 100644 (file)
index 0000000..430d587
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# mpir
+#
+################################################################################
+
+MPIR_VERSION = 3.0.0
+MPIR_SITE = http://www.mpir.org
+MPIR_SOURCE = mpir-$(MPIR_VERSION).tar.bz2
+MPIR_LICENSE = LGPL-3.0+
+MPIR_LICENSE_FILES = COPYING.LIB
+MPIR_INSTALL_STAGING = YES
+MPIR_DEPENDENCIES = gmp host-yasm
+
+$(eval $(autotools-package))