ramspeed: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 May 2012 12:33:18 +0000 (12:33 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jun 2012 21:58:33 +0000 (23:58 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/ramspeed/Config.in [new file with mode: 0644]
package/ramspeed/Makefile [new file with mode: 0644]
package/ramspeed/ramspeed.mk [new file with mode: 0644]

index ddb504a12cf16a801db9c046ec4ea2f06e63e5a5..d047ce833986f9a97487e67182ab2eaffe114beb 100644 (file)
@@ -35,6 +35,7 @@ source "package/ltrace/Config.in"
 source "package/memstat/Config.in"
 source "package/netperf/Config.in"
 source "package/oprofile/Config.in"
+source "package/ramspeed/Config.in"
 source "package/rt-tests/Config.in"
 source "package/strace/Config.in"
 source "package/stress/Config.in"
diff --git a/package/ramspeed/Config.in b/package/ramspeed/Config.in
new file mode 100644 (file)
index 0000000..b236329
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RAMSPEED
+       bool "ramspeed"
+       help
+         RAMspeed is a free open source command line utility
+         to measure cache and memory performance.
+
+         http://alasir.com/software/ramspeed/
diff --git a/package/ramspeed/Makefile b/package/ramspeed/Makefile
new file mode 100644 (file)
index 0000000..acb8cfd
--- /dev/null
@@ -0,0 +1,14 @@
+
+all: generic
+
+generic: ramspeed.c fltmem.c fltmark.c intmem.c intmark.c
+       $(CC) $(CFLAGS) $^ -o ramspeed
+
+i386: ramspeed.c i386/*.s i386/cpuinfo/*.s
+       $(CC) $(CFLAGS) -DI386_ASM $^ -o ramspeed
+
+x86_64: ramspeed.c amd64/*.s
+       $(CC) $(CFLAGS) -DAMD64_ASM $^ -o ramspeed
+
+clean:
+       rm -f *.o ramspeed
diff --git a/package/ramspeed/ramspeed.mk b/package/ramspeed/ramspeed.mk
new file mode 100644 (file)
index 0000000..9ac21ad
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# ramspeed
+#
+#############################################################
+
+RAMSPEED_VERSION = 2.6.0
+RAMSPEED_SITE = http://www.alasir.com/software/ramspeed
+RAMSPEED_ARCH = $(if $(BR2_i386),i386)$(if $(BR2_x86_64),x86_64)
+
+define RAMSPEED_BUILD_CMDS
+       cp -f package/ramspeed/Makefile $(@D)
+       CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+               make -C $(@D) $(RAMSPEED_ARCH)
+endef
+
+define RAMSPEED_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/ramspeed $(TARGET_DIR)/usr/bin/ramspeed
+endef
+
+$(eval $(call GENTARGETS))