package/lvm2: add missing host-pkgconf dependency
authorRomain Naour <romain.naour@gmail.com>
Wed, 13 Sep 2017 20:17:55 +0000 (22:17 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 12:38:36 +0000 (14:38 +0200)
configure.ac use PKG_CHECK_MODULES macro to find some libraries dependencies.
So add host-pkgconf in LVM2_DEPENDENCIES.

Fixes:
checking pkg-config is at least version 0.9.0... ./configure: line 9875: [...]/host/bin/pkg-config: No such file or directory

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/lvm2/lvm2.mk

index 63ac109ca90603b3b43193fcbbd0e3b69e8c5d69..f7f706976f5ab356cb4d681ecded5b8679f1e690 100644 (file)
@@ -21,6 +21,8 @@ LVM2_CONF_OPTS += \
        --enable-dmeventd \
        --disable-nls
 
+LVM2_DEPENDENCIES += host-pkgconf
+
 # LVM2 uses autoconf, but not automake, and the build system does not
 # take into account the toolchain passed at configure time.
 LVM2_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)