perl-gd: bump to version 2.59
authorFrancois Perrad <fperrad@gmail.com>
Sat, 22 Apr 2017 06:34:06 +0000 (08:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Apr 2017 13:06:56 +0000 (15:06 +0200)
remove patches merged upstream

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: renumber patches.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perl-gd/0001-gdlib-config-is-now-configurable.patch [new file with mode: 0644]
package/perl-gd/0001-getoptions.patch [deleted file]
package/perl-gd/0002-lgd.patch [deleted file]
package/perl-gd/0003-force.patch [deleted file]
package/perl-gd/0004-gdlib-config-is-now-configurable.patch [deleted file]
package/perl-gd/Config.in
package/perl-gd/perl-gd.hash
package/perl-gd/perl-gd.mk

diff --git a/package/perl-gd/0001-gdlib-config-is-now-configurable.patch b/package/perl-gd/0001-gdlib-config-is-now-configurable.patch
new file mode 100644 (file)
index 0000000..294279a
--- /dev/null
@@ -0,0 +1,67 @@
+From f417f38929fe558d388b9a9343da9b2c0e6984aa Mon Sep 17 00:00:00 2001
+From: Romain Naour <romain.naour@openwide.fr>
+Date: Sat, 20 Dec 2014 23:22:41 +0100
+Subject: [PATCH] Makefile.PL: gdlib-config is now configurable
+
+Signed-off-by: Romain Naour <romain.naour@openwide.fr>
+---
+ Makefile.PL | 15 +++++++++++++--
+ 1 file changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index dfe8ad7..0fa6ef3 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -21,7 +21,7 @@ END
+ my (@INC,@LIBPATH,@LIBS,$LIBGD_VERSION);
+ my $AUTOCONFIG = 0;      # global set by try_to_autoconfigure() below
+-my ($options,$lib_gd_path,$lib_ft_path,$lib_png_path,$lib_jpeg_path,$lib_xpm_path,$lib_zlib_path,$force);
++my ($options,$lib_gd_path,$lib_ft_path,$lib_png_path,$lib_jpeg_path,$lib_xpm_path,$lib_zlib_path,$force,$gdlib_config_path);
+ use Getopt::Long;
+ my $result = GetOptions("ignore_missing_gd" => \$force,
+@@ -32,6 +32,7 @@ my $result = GetOptions("ignore_missing_gd" => \$force,
+                       "lib_jpeg_path=s" => \$lib_jpeg_path,
+                       "lib_xpm_path=s"  => \$lib_xpm_path,
+                       "lib_zlib_path=s" => \$lib_zlib_path,
++                      "gdlib_config_path=s" => \$gdlib_config_path,
+                      );
+ unless (try_to_autoconfigure(\$options,\$lib_gd_path,\@INC,\@LIBPATH,\@LIBS) || $force) {
+@@ -75,6 +76,7 @@ Configure GD module.
+      -lib_xpm_path  path            path to libxpm
+      -lib_zlib_path path            path to libpng
+      -ignore_missing_gd             Ignore missing or old libgd installations and try to compile anyway
++     -gdlib_config_path path        path to gdlib-config
+ If no options are passed on the command line.  The program will
+ attempt to autoconfigure itself with the gdlib-config program (present
+@@ -121,6 +123,15 @@ if( defined($lib_zlib_path) )
+     @INC     = ("-I$lib_zlib_path/include", @INC);
+     @LIBPATH = ("-L$lib_zlib_path/lib", @LIBPATH); 
+ }
++if( defined($gdlib_config_path) )
++{
++    print "gdlib-config used:          $gdlib_config_path\n";
++}
++else
++{
++    $gdlib_config_path = "gdlib-config";
++    print "$gdlib_config_path used from the PATH\n";
++}
+ #############################################################################################
+ if ($^O eq 'VMS'){
+@@ -289,7 +300,7 @@ sub try_to_autoconfigure {
+   my ($prefix) = $$lib_gd_path ? ($$lib_gd_path =~ m|(^.*)/lib|) : "";
+   my $bindir = $prefix ? "$prefix/bin/" : "";
+   my $config = `${bindir}gdlib-config --all` if -e "${bindir}gdlib-config";
+-  $config = `gdlib-config --all` if !$config;
++  $config = `$gdlib_config_path --all` if !$config;
+   unless ($config) {
+       my %config;
+       require ExtUtils::PkgConfig;
+-- 
+1.9.3
+
diff --git a/package/perl-gd/0001-getoptions.patch b/package/perl-gd/0001-getoptions.patch
deleted file mode 100644 (file)
index 74f055b..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-fix option handling in Makefile.PL
-
-the call to GetOptions() must be unique.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-see https://github.com/lstein/Perl-GD/pull/6
-
-Index: b/Makefile.PL
-===================================================================
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -24,7 +24,15 @@
- my ($options,$lib_gd_path,$lib_ft_path,$lib_png_path,$lib_jpeg_path,$lib_xpm_path,$lib_zlib_path,$force);
- use Getopt::Long;
--GetOptions("ignore_missing_gd" => \$force);
-+my $result = GetOptions("options=s"         => \$options,
-+                      "lib_gd_path=s"     => \$lib_gd_path,
-+                      "lib_ft_path=s"     => \$lib_ft_path,
-+                      "lib_png_path=s"    => \$lib_png_path,
-+                      "lib_jpeg_path=s"   => \$lib_jpeg_path,
-+                      "lib_xpm_path=s"    => \$lib_xpm_path,
-+                      "lib_zlib_path=s"   => \$lib_zlib_path,
-+                      "ignore_missing_gd" => \$force,
-+                     );
- unless (try_to_autoconfigure(\$options,\$lib_gd_path,\@INC,\@LIBPATH,\@LIBS) || $force) {
-     die <<END;
-@@ -47,14 +55,6 @@
- #############################################################################################
- # Build options passed in to script to support reproducible builds via Makefiles
- #############################################################################################
--my $result = GetOptions("options=s"       => \$options,
--                      "lib_gd_path=s"   => \$lib_gd_path,
--                      "lib_ft_path=s"   => \$lib_ft_path,
--                      "lib_png_path=s"  => \$lib_png_path,
--                      "lib_jpeg_path=s" => \$lib_jpeg_path,
--                      "lib_xpm_path=s"  => \$lib_xpm_path,
--                      "lib_zlib_path=s" => \$lib_zlib_path,
--                     );
- unless ($result) {
-   print STDERR <<END;
- Usage: perl Makefile.PL [options]
diff --git a/package/perl-gd/0002-lgd.patch b/package/perl-gd/0002-lgd.patch
deleted file mode 100644 (file)
index 2827cd7..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-refactor -lgd in @LIBS
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-see https://github.com/lstein/Perl-GD/pull/7
-
-Index: b/Makefile.PL
-===================================================================
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -42,9 +42,9 @@
- END
- }
-+push @LIBS, "-lgd";
- @INC     = qw(-I/usr/include -I/usr/include/gd) unless @INC;
- @LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
--@LIBS    = qw(-lgd) unless @LIBS;
- # support for AMD64 libraries
- if (-d '/usr/lib64') {
-@@ -294,7 +294,6 @@
-   @$LIBPATH      = map {s/^-L// && "-L$_"} split /\s+/,$ldflags;
-   @$LIBS         = split /\s+/,$libs;
--  push @$LIBS,"-lgd";
-   push @$LIBPATH,"-L$libdir";
-   ($$lib_gd_path = $libdir) =~ s!/[^/]+$!!;
-   $$options      = $features;
diff --git a/package/perl-gd/0003-force.patch b/package/perl-gd/0003-force.patch
deleted file mode 100644 (file)
index 611066b..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-let @INC and @LIBPATH empty when ignore_missing_gd
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-see https://github.com/lstein/Perl-GD/pull/7
-
-Index: b/Makefile.PL
-===================================================================
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -43,13 +43,15 @@
- }
- push @LIBS, "-lgd";
--@INC     = qw(-I/usr/include -I/usr/include/gd) unless @INC;
--@LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
--
--# support for AMD64 libraries
--if (-d '/usr/lib64') {
--  my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
--  @LIBPATH = (@LIBPATH,@libs64);
-+unless ($force) {
-+  @INC     = qw(-I/usr/include -I/usr/include/gd) unless @INC;
-+  @LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
-+
-+  # support for AMD64 libraries
-+  if (-d '/usr/lib64') {
-+    my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
-+    @LIBPATH = (@LIBPATH,@libs64);
-+  }
- }
- #############################################################################################
diff --git a/package/perl-gd/0004-gdlib-config-is-now-configurable.patch b/package/perl-gd/0004-gdlib-config-is-now-configurable.patch
deleted file mode 100644 (file)
index 58df225..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-From f417f38929fe558d388b9a9343da9b2c0e6984aa Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Sat, 20 Dec 2014 23:22:41 +0100
-Subject: [PATCH] Makefile.PL: gdlib-config is now configurable
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
----
- Makefile.PL | 15 +++++++++++++--
- 1 file changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile.PL b/Makefile.PL
-index dfe8ad7..0fa6ef3 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -21,7 +21,7 @@ END
- my (@INC,@LIBPATH,@LIBS);
- my $AUTOCONFIG = 0;      # global set by try_to_autoconfigure() below
--my ($options,$lib_gd_path,$lib_ft_path,$lib_png_path,$lib_jpeg_path,$lib_xpm_path,$lib_zlib_path,$force);
-+my ($options,$lib_gd_path,$lib_ft_path,$lib_png_path,$lib_jpeg_path,$lib_xpm_path,$lib_zlib_path,$force,$gdlib_config_path);
- use Getopt::Long;
- my $result = GetOptions("options=s"         => \$options,
-@@ -32,6 +32,7 @@ my $result = GetOptions("options=s"         => \$options,
-                       "lib_xpm_path=s"    => \$lib_xpm_path,
-                       "lib_zlib_path=s"   => \$lib_zlib_path,
-                       "ignore_missing_gd" => \$force,
-+                      "gdlib_config_path=s" => \$gdlib_config_path,
-                      );
- unless (try_to_autoconfigure(\$options,\$lib_gd_path,\@INC,\@LIBPATH,\@LIBS) || $force) {
-@@ -72,6 +73,7 @@ Configure GD module.
-      -lib_xpm_path  path            path to libxpm
-      -lib_zlib_path path            path to libpng
-      -ignore_missing_gd             Ignore missing or old libgd installations and try to compile anyway
-+     -gdlib_config_path path        path to gdlib-config
- If no options are passed on the command line.  The program will
- attempt to autoconfigure itself with the gdlib-config program (present
-@@ -118,6 +120,15 @@ if( defined($lib_zlib_path) )
-     @INC     = ("-I$lib_zlib_path/include", @INC);
-     @LIBPATH = ("-L$lib_zlib_path/lib", @LIBPATH); 
- }
-+if( defined($gdlib_config_path) )
-+{
-+    print "gdlib-config used:          $gdlib_config_path\n";
-+}
-+else
-+{
-+    $gdlib_config_path = "gdlib-config";
-+    print "$gdlib_config_path used from the PATH\n";
-+}
- #############################################################################################
- if ($^O eq 'VMS'){
-@@ -278,7 +289,7 @@ exit 0;
- sub try_to_autoconfigure {
-   my ($options,$lib_gd_path,$INC,$LIBPATH,$LIBS) = @_;
--  my $config = `gdlib-config --all`;
-+  my $config = `$gdlib_config_path --all`;
-   return unless $config;
-   $AUTOCONFIG++;
--- 
-1.9.3
-
index 2b7a265f155eed208858c7d47cef7ca62e18a5c2..61f7e5dadcd7f85c8b4d955115ab554cdeef456f 100644 (file)
@@ -6,7 +6,7 @@ config BR2_PACKAGE_PERL_GD
        select BR2_PACKAGE_FREETYPE
        select BR2_PACKAGE_GD
        help
-         Perl interface to the gd2 graphics library
+         Interface to Gd Graphics Library
 
          https://metacpan.org/release/GD
 
index 0c16d3f521e0fbf562b6d488cf35512ceaa63fed..07f24710fee503ad6cb92d56f24877cfb13edaa1 100644 (file)
@@ -1,3 +1,3 @@
 # retrieved by scancpan from http://cpan.metacpan.org/
-md5    c4b3afd98b2c4ce3c2e1027d101a8f1e GD-2.56.tar.gz
-sha256 1f103d1c98de8621504642ed7fb79f1b40f5f6a63c2abe9390a8ab78617248f9 GD-2.56.tar.gz
+md5    b77596aedf8ba92106ada82c7a58dd29 GD-2.59.tar.gz
+sha256 b5f22854be579cd9c1696f4a5175d57f5623d3bf2e75173ffa8038a1a28afad6 GD-2.59.tar.gz
index 89a21cf3e946ba9d6c78e5e6a8c86af965ee55c0..28a1b876e2c9ee1f68d20bbbe3318aab47fbbf53 100644 (file)
@@ -4,18 +4,12 @@
 #
 ################################################################################
 
-PERL_GD_VERSION = 2.56
+PERL_GD_VERSION = 2.59
 PERL_GD_SOURCE = GD-$(PERL_GD_VERSION).tar.gz
-PERL_GD_SITE = $(BR2_CPAN_MIRROR)/authors/id/L/LD/LDS
+PERL_GD_SITE = $(BR2_CPAN_MIRROR)/authors/id/R/RU/RURBAN
 PERL_GD_DEPENDENCIES = zlib libpng freetype gd
 PERL_GD_LICENSE = Artistic or GPL-1.0+
 PERL_GD_LICENSE_FILES = LICENSE
-PERL_GD_PREFER_INSTALLER = EUMM
-
-define PERL_GD_MOVE_XS
-       mv $(@D)/lib/GD.xs $(@D)/GD.xs
-endef
-PERL_GD_POST_PATCH_HOOKS += PERL_GD_MOVE_XS
 
 PERL_GD_CONF_OPTS = \
        -options=FT,PNG \