Update tar version. Minor fix for gcc includes when NOT
authorEric Andersen <andersen@codepoet.org>
Sun, 23 Feb 2003 08:54:13 +0000 (08:54 -0000)
committerEric Andersen <andersen@codepoet.org>
Sun, 23 Feb 2003 08:54:13 +0000 (08:54 -0000)
building a bootstrapping toolchain.

make/gcc_target.mk
make/tar.mk

index 2e60b81f7cd331a7a1a5555ee368cbc73cf2660d..5d9cb25b7c72c0a123da0a70317021aa0d3e7b23 100644 (file)
@@ -385,9 +385,11 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        rm -f $(TARGET_DIR)/usr/lib/*.la*
        # gcc "fixincludes" step is totally broken and takes unwanted
        # stuff from the host system.  Fix that here.
+ifeq ($(USE_UCLIBC_TOOLCHAIN),true)
        rm -rf $(TARGET_DIR)/usr/lib/gcc-lib/$(GNU_TARGET_NAME)/*/include/*
        -cp -a $(STAGING_DIR)/usr/lib/gcc-lib/$(GNU_TARGET_NAME)/*/include/* \
                $(TARGET_DIR)/usr/lib/gcc-lib/$(GNU_TARGET_NAME)/*/include/
+endif
        touch -c $(TARGET_DIR)/usr/bin/gcc
 
 gcc_target: uclibc_target binutils_target $(TARGET_DIR)/usr/bin/gcc
index 1e31c1082c619824ec2a80b80f17831c35a210cc..168f2543bac9a205da3c09fa8e0dee076ad07d4f 100644 (file)
@@ -3,9 +3,9 @@
 # tar
 #
 #############################################################
-GNUTAR_SOURCE:=tar-1.13.tar.gz
-GNUTAR_SITE:=ftp://ftp.gnu.org/gnu/tar
-GNUTAR_DIR:=$(BUILD_DIR)/tar-1.13
+GNUTAR_SOURCE:=tar-1.13.25.tar.gz
+GNUTAR_SITE:=ftp://alpha.gnu.org/gnu/tar
+GNUTAR_DIR:=$(BUILD_DIR)/tar-1.13.25
 GNUTAR_CAT:=zcat
 GNUTAR_BINARY:=src/tar
 GNUTAR_TARGET_BINARY:=bin/tar