kconfig infra: remove all install stamp files
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Tue, 3 Feb 2015 14:21:44 +0000 (15:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Feb 2015 15:34:26 +0000 (16:34 +0100)
Some packages (like linux) may install things inside images/ as well, so
remove the associated stamp file after running the configuration editor.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: "Yann E. Morin" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index f76c7a79f58fd7dc72d2c5a9fb89e05378549b75..8e6831521ae6d1839d0efe3ac68a183dd2bfca97 100644 (file)
@@ -71,7 +71,7 @@ $$(addprefix $(1)-,$$($(2)_KCONFIG_EDITORS)): $$($(2)_DIR)/.stamp_kconfig_fixup_
        $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
                $$($(2)_KCONFIG_OPTS) $$(subst $(1)-,,$$@)
        rm -f $$($(2)_DIR)/.stamp_{kconfig_fixup_done,configured,built}
-       rm -f $$($(2)_DIR)/.stamp_{target,staging}_installed
+       rm -f $$($(2)_DIR)/.stamp_{target,staging,images}_installed
 
 $(1)-savedefconfig: $$($(2)_DIR)/.stamp_kconfig_fixup_done
        $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \