toolchain: remove no longer relevant comment
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Mar 2017 20:28:52 +0000 (21:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Mar 2017 20:28:52 +0000 (21:28 +0100)
The somewhat complicated sed expression has been removed in commit
06cd604ec6d34f25b436ab729543418042a87e1c ("toolchain/external: use
-dumpversion to check gcc version"), so let's remove the comment that
was explaining this sed expression.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/helpers.mk

index 6044b7e5f499e7591663317f8a28fe5c84151f26..2f73ebbe8bb370c4edb80308f46729bfa97265e4 100644 (file)
@@ -133,16 +133,6 @@ check_kernel_headers_version = \
 # $1: path to gcc
 # $2: expected gcc version
 #
-# Some details about the sed expression:
-# - 1!d
-#   - delete if not line 1
-#
-# - s/^[^)]+\) ([^[:space:]]+).*/\1/
-#   - eat all until the first ')' character followed by a space
-#   - match as many non-space chars as possible
-#   - eat all the remaining chars on the line
-#   - replace by the matched expression
-#
 check_gcc_version = \
        expected_version="$(strip $2)" ; \
        if [ -z "$${expected_version}" ]; then \