package/efl/libefl: add harfbuzz dependency
authorRomain Naour <romain.naour@openwide.fr>
Tue, 15 Dec 2015 22:40:14 +0000 (23:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 22:52:55 +0000 (23:52 +0100)
Harfbuzz allow to enable complex text shaping and layouting support in
efl libraries.

Also, it one of the "highly recommended" dependencies according to the
README but disabling it doesn't need the
--enable-i-really-know-what-i-am-doing... option.  That's why harfbuzz
is not added to BR2_PACKAGE_LIBEFL_HAS_RECOMMENDED_CONFIG.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libefl/libefl.mk

index 615968ea4c8e469779a20d10221be85a5b79c9c7..184604b22187c83ca0b70cbed29975e4fd3e15dc 100644 (file)
@@ -31,7 +31,6 @@ LIBEFL_GETTEXTIZE = YES
 # Configure options:
 # --disable-cxx-bindings: disable C++11 bindings.
 # --disable-fb: disable frame buffer support.
-# --disable-harfbuzz: disable harfbuzz support.
 # --disable-image-loader-jp2k: disable JPEG 2000 support.
 # --disable-image-loader-webp: disable webp support.
 # --disable-sdl: disable sdl2 support.
@@ -45,7 +44,6 @@ LIBEFL_CONF_OPTS = \
        --with-eolian-gen=$(HOST_DIR)/usr/bin/eolian_gen \
        --disable-cxx-bindings \
        --disable-fb \
-       --disable-harfbuzz \
        --disable-image-loader-jp2k \
        --disable-image-loader-webp \
        --disable-sdl \
@@ -109,6 +107,13 @@ else
 LIBEFL_CONF_OPTS += --disable-pulseaudio
 endif
 
+ifeq ($(BR2_PACKAGE_HARFBUZZ),y)
+LIBEFL_DEPENDENCIES += harfbuzz
+LIBEFL_CONF_OPTS += --enable-harfbuzz
+else
+LIBEFL_CONF_OPTS += --disable-harfbuzz
+endif
+
 ifeq ($(BR2_PACKAGE_TSLIB),y)
 LIBEFL_DEPENDENCIES += tslib
 LIBEFL_CONF_OPTS += --enable-tslib