dropwatch: fix avr32 build failure
authorSimon Dawson <spdawson@gmail.com>
Tue, 5 Nov 2013 07:55:14 +0000 (07:55 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Nov 2013 13:25:51 +0000 (14:25 +0100)
On avr32, dropwatch needs libiberty to avoid build failures such as

  http://autobuild.buildroot.net/results/cd5/cd5e22fb5c9b0fc5d396bc85a5e253a1a65054da/

Also test built on ARM.

[Peter: pass TARGET_LDFLAGS as well, append -lintl in gettext case]
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dropwatch/dropwatch.mk

index 5d65d86699bf3ddc90c5a6fffaf08063d6c08caa..6bbcb234c8cd624bd780bee05883497b8d8df2eb 100644 (file)
@@ -13,13 +13,18 @@ DROPWATCH_LICENSE_FILES = COPYING
 
 # libbfd may be linked to libintl
 # Ugly... but LDFLAGS are hardcoded anyway
+#
+# Also: always need to add -liberty to hardcoded LDFLAGS for avr32
+DROPWATCH_LDFLAGS = \
+       $(TARGET_LDFLAGS) -lbfd -liberty -lreadline -lnl-3 -lnl-genl-3
+
 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-DROPWATCH_LDFLAGS = LDFLAGS="-lintl -lbfd -lreadline -lnl-3 -lnl-genl-3"
+DROPWATCH_LDFLAGS += -lintl
 endif
 
 define DROPWATCH_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
-               $(DROPWATCH_LDFLAGS) build
+               LDFLAGS="$(DROPWATCH_LDFLAGS)" build
 endef
 
 define DROPWATCH_CLEAN_CMDS