libucl: new package
authorNimai Mahajan <nimaim@gmail.com>
Fri, 26 Jun 2015 14:19:43 +0000 (10:19 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 26 Jun 2015 18:21:53 +0000 (20:21 +0200)
Libucl is a high performance and flexible JSON/YAML/etc. parser for C.

https://github.com/vstakhov/libucl

[Thomas:
  - remove hash file, should not be used for github downloads
  - rewrap Config.in help text
  - remove trailing white space in Config.in.
  - add missing host-pkgconf dependency, without which the package
    doesn't autoreconf properly.
  - fix license: it is BSD-2c, not just BSD.]

Signed-off-by: Nimai Mahajan <nimaim@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libucl/Config.in [new file with mode: 0644]
package/libucl/libucl.mk [new file with mode: 0644]

index fac632f00e1589d1b4d03681292a755d50bf3f31..9dbc98fb7f13f0a4cbfd7ca2d3f5de593505e5a0 100644 (file)
@@ -881,6 +881,7 @@ menu "JSON/XML"
        source "package/jsoncpp/Config.in"
        source "package/libjson/Config.in"
        source "package/libroxml/Config.in"
+       source "package/libucl/Config.in"
        source "package/libxml2/Config.in"
        source "package/libxmlpp/Config.in"
        source "package/libxmlrpc/Config.in"
diff --git a/package/libucl/Config.in b/package/libucl/Config.in
new file mode 100644 (file)
index 0000000..a94701e
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_LIBUCL
+       bool "libucl"
+       help
+         Universal configuration library parser
+
+         Libucl is a parser and C API to parse and generate ucl
+         objects. Libucl consist of several groups of functions:
+         parser, emitting, conversion, generation, iteration,
+         validation, and utility. These functions can be used to work
+         with several formats: JSON, compact JSON, configuration
+         (nginx like), and YAML. Libucl has clear design that should
+         be very convenient for reading and writing and makes for an
+         ideal parser with high performance.
+
+         https://github.com/vstakhov/libucl
diff --git a/package/libucl/libucl.mk b/package/libucl/libucl.mk
new file mode 100644 (file)
index 0000000..3530bbe
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libucl
+#
+################################################################################
+
+LIBUCL_VERSION = 0.7.3
+LIBUCL_SITE = $(call github,vstakhov,libucl,$(LIBUCL_VERSION))
+LIBUCL_INSTALL_STAGING = YES
+LIBUCL_AUTORECONF = YES
+LIBUCL_LICENSE = BSD-2c
+LIBUCL_LICENSE_FILES = COPYING
+LIBUCL_DEPENDENCIES = host-pkgconf
+
+$(eval $(autotools-package))