tremor: fix svn checkout
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 1 Jul 2010 15:33:29 +0000 (17:33 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 1 Jul 2010 15:33:29 +0000 (17:33 +0200)
Commit 1dc19c445 (split tremor into its own package) unfortunately
broke the svn checkout step (but normally not noticable as we have
a tarball on sources.buildroot.net that will get downloaded instead).

Fix it by using a custom download step, and remove unused variables
while we're at it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/tremor/tremor.mk

diff --git a/CHANGES b/CHANGES
index 9e672f1cb89ccbc314733b7643d5b047f73aeee5..91d3cf14322a1ae5ad15b56d59010b6a237452e6 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -19,7 +19,7 @@
        libart, libfuse, libgpg-error, libidn, liblockfile, links,
        lmbench, lrzsz, make, module-init-tools, nbd, ncurses, netperf,
        ntfsprogs, openssl, php, qt, quagga, sqlite, sdl, sdl_mixer,
-       sdl_ttf, squashfs, tn5250, usbutils, xkeyboard-config,
+       sdl_ttf, squashfs, tn5250, tremor, usbutils, xkeyboard-config,
        xserver_xorg-server
 
        Removed packages: modutils, portage, rxvt
index b49337542bf5392fb89d66ab29c099525579b394..74fd725ff01b273f5b77c4fceceb23c1f09aeb43 100644 (file)
@@ -4,28 +4,20 @@
 #
 ############################################################
 
-TREMOR_TRUNK:=http://svn.xiph.org/trunk/Tremor/
+TREMOR_SITE:=http://svn.xiph.org/trunk/Tremor/
 TREMOR_VERSION:=16259
-TREMOR_NAME:=Tremor-svn-r$(TREMOR_VERSION)
-TREMOR_DIR:=$(BUILD_DIR)/$(TREMOR_NAME)
-TREMOR_SOURCE:=$(TREMOR_NAME).tar.bz2
-TREMOR_CAT=$(BZCAT)
+TREMOR_SVNDIR = Tremor-svn-r$(TREMOR_VERSION)
+TREMOR_SOURCE:= $(TREMOR_SVNDIR).tar.bz2
 TREMOR_AUTORECONF = YES
 TREMOR_INSTALL_STAGING = YES
 TREMOR_INSTALL_TARGET = YES
 
 $(DL_DIR)/$(TREMOR_SOURCE):
-       $(SVN_CO) -r $(TREMOR_VERSION) $(TREMOR_TRUNK) $(TREMOR_DIR)
-       tar -cv -C $(BUILD_DIR) $(TREMOR_NAME) | bzip2 - -c > $@
-
-$(eval $(call AUTOTARGETS,package/multimedia,tremor))
+       $(SVN_CO) -r $(TREMOR_VERSION) $(TREMOR_SITE) $(BUILD_DIR)/$(TREMOR_SVNDIR)
+       tar -cv -C $(BUILD_DIR) $(TREMOR_SVNDIR) | bzip2 - -c > $@
+       rm -rf $(BUILD_DIR)/$(TREMOR_SVNDIR)
 
+# use custom download step
+TREMOR_TARGET_SOURCE := $(DL_DIR)/$(TREMOR_SOURCE)
 
-############################################################
-#
-# Toplevel Makefile options
-#
-############################################################
-ifeq ($(BR2_PACKAGE_TREMOR),y)
-TARGETS+=tremor
-endif
+$(eval $(call AUTOTARGETS,package/multimedia,tremor))