mpv: jack/sdl/sdl2 require 64-bit sync intrinsics
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 28 Apr 2016 13:20:18 +0000 (10:20 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 May 2016 20:56:35 +0000 (22:56 +0200)
Fixes:
http://autobuild.buildroot.net/results/578/578beb2f3b34fc83109e79d8db7de7219dd8340e/
http://autobuild.buildroot.net/results/21c/21ce67041792d29082f5bba76299da19dd1856eb/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpv/mpv.mk

index 3c6e3922b6f2794ce33c2af205bbdabf8161ce03..cd8c31bd8f328344fb3422e79b730692a51256d5 100644 (file)
@@ -52,7 +52,8 @@ MPV_CONF_OPTS += --disable-gbm
 endif
 
 # jack support
-ifeq ($(BR2_PACKAGE_JACK2),y)
+# It also requires 64-bit sync intrinsics
+ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_8)$(BR2_PACKAGE_JACK2),yy)
 MPV_CONF_OPTS += --enable-jack
 MPV_DEPENDENCIES += jack2
 else
@@ -166,10 +167,11 @@ endif
 
 # SDL support
 # Both can't be used at the same time, prefer newer API
-ifeq ($(BR2_PACKAGE_SDL2),y)
+# It also requires 64-bit sync intrinsics
+ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_8)$(BR2_PACKAGE_SDL2),yy)
 MPV_CONF_OPTS += --enable-sdl2 --disable-sdl1
 MPV_DEPENDENCIES += sdl2
-else ifeq ($(BR2_PACKAGE_SDL),y)
+else ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_8)$(BR2_PACKAGE_SDL),yy)
 MPV_CONF_OPTS += --enable-sdl1 --disable-sdl2
 MPV_DEPENDENCIES += sdl
 else