package/efl/libevas: x-includes and x-libraries must be set for cross-compiling
authorRomain Naour <romain.naour@openwide.fr>
Sat, 2 May 2015 20:16:36 +0000 (22:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 May 2015 09:44:13 +0000 (11:44 +0200)
evas_engine_software_xlib_cflags and evas_engine_software_xlib_libs
contains unsafe libraries paths if x-include and x-libraries are
not set in libevas.mk.

config.log:
evas_engine_software_xlib_cflags='-I/usr/X11R6/include'
evas_engine_software_xlib_libs='-L/usr/X11R6/lib -lX11 -lXext'

Fixes:
http://autobuild.buildroot.net/results/e5f/e5fb1e62cb634b20233751b4ea3b0630de70e9e0/

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libevas/libevas.mk

index 83129025cf8bf546323dbf01f0ffe57818051be6..8113162c4e9286908ec3f8a6ef1d495d72df29d8 100644 (file)
@@ -63,7 +63,10 @@ LIBEVAS_CONF_OPTS += --enable-buffer
 endif
 
 ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
-LIBEVAS_CONF_OPTS += --enable-software-xlib
+LIBEVAS_CONF_OPTS += --enable-software-xlib \
+       --with-x=$(STAGING_DIR) \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
 LIBEVAS_DEPENDENCIES += xlib_libX11 xlib_libXext
 else
 LIBEVAS_CONF_OPTS += --disable-software-xlib