toolchain: speed up sysroot lib copying
authorMike Frysinger <vapier@gentoo.org>
Sun, 9 Oct 2011 17:44:32 +0000 (19:44 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Oct 2011 07:47:23 +0000 (09:47 +0200)
The copy_toolchain_lib_root helper searches the entire sysroot, but is
only interested in files in certain subdirs.  So rather than waste time
in walking the entire tree, walk the few subdirs at the depth level we
are actually going to be poaching files from.

Some simplification suggested by Yann E. MORIN
<yann.morin.1998@anciens.enib.fr> and Arnout Vandecappelle
<arnout@mind.be>, added by Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index 7f3efaa40dd1218938cdd30893c84caf736cf3b0..5585f45fe3c5c50241aa447e6620f6c04ba60223 100644 (file)
@@ -22,9 +22,8 @@ copy_toolchain_lib_root = \
        DESTDIR="$(strip $3)" ; \
  \
        LIBS=`(cd $${ARCH_SYSROOT_DIR}; \
-               find -L . -path "./lib/$${LIB}.*"     -o \
-                         -path "./usr/lib/$${LIB}.*" -o \
-                         -path "./usr/$(TOOLCHAIN_EXTERNAL_PREFIX)/lib*/$${LIB}.*" \
+               find -L lib* usr/lib* usr/$(TOOLCHAIN_EXTERNAL_PREFIX)/lib* \
+                       -maxdepth 1 -name "$${LIB}.*" 2>/dev/null \
                )` ; \
        for FILE in $${LIBS} ; do \
                LIB=`basename $${FILE}`; \