nasm: new package, needed for syslinux
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 31 May 2010 19:08:14 +0000 (21:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Jun 2010 11:38:45 +0000 (13:38 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nasm/nasm.mk [new file with mode: 0644]

diff --git a/package/nasm/nasm.mk b/package/nasm/nasm.mk
new file mode 100644 (file)
index 0000000..08983e1
--- /dev/null
@@ -0,0 +1,19 @@
+############################################################
+#
+# nasm
+#
+# This is special case: nasm is used to build syslinux and
+# pxelinux. As these are for the target, we should cross-compile
+# nasm. However, as nasm is x86-only, there's no point in
+# cross-compiling it. So we just build it for the host. The target
+# variant is only provided because of a bug in the package
+# infrastructure that prevents having only a host variant.
+############################################################
+
+NASM_VERSION=2.08.01
+NASM_SOURCE=nasm-$(NASM_VERSION).tar.bz2
+NASM_SITE=http://www.nasm.us/pub/nasm/releasebuilds/2.08.01/
+NASM_LIBTOOL_PATCH=NO
+
+$(eval $(call AUTOTARGETS,package,nasm))
+$(eval $(call AUTOTARGETS,package,nasm,host))