qt5base: add optional gstreamer1 support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 21 Oct 2015 08:06:29 +0000 (10:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Oct 2015 20:01:36 +0000 (21:01 +0100)
Indirectly fixes:
http://autobuild.buildroot.net/results/773/773d9996bd3da283eed6b75083b8bab6469d0423/
http://autobuild.buildroot.net/results/069/069f564fde821b55e710fbe93fe30a5cf11a6da5/
http://autobuild.buildroot.net/results/456/456d380f8b4478245e89f711c33fe0c2d23aaa3a/
http://autobuild.buildroot.net/results/7c8/7c8ebfc93a5b11e40251495715d742520b3b8291/

And many more, as qt5multimedia needs qt5base to be built with gstreamer1
support as well.

While qt5 has some gstreamer 0.10 support, it doesn't seem to be used much
any more and E.G. the 0.10 fallback code in qt5multimedia is broken so only
enable it for the 1.x series.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5base/qt5base.mk

index 3d1ada427870c6a839a0ad4ed6a4c20a2091a036..827a85e982a338cddcb5fbd43fffc5314cdfaf2e 100644 (file)
@@ -147,6 +147,14 @@ QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_ICU),icu)
 
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_EXAMPLES),-make,-nomake) examples
 
+# gstreamer 0.10 support is broken in qt5multimedia
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
+QT5BASE_CONFIGURE_OPTS += -gstreamer 1.0
+QT5BASE_DEPENDENCIES   += gst1-plugins-base
+else
+QT5BASE_CONFIGURE_OPTS += -no-gstreamer
+endif
+
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_XCB)        += Qt5XcbQpa