libupnp18: new package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 18 Nov 2017 20:24:40 +0000 (21:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Nov 2017 20:41:08 +0000 (21:41 +0100)
Branch 1.8.x of libupnp is not compatible with branch 1.6.x so add a
dedicated package and make it depends on !BR2_PACKAGE_LIBUPNP as
suggested by Thomas Petazzoni and Arnout Vandecappelle during review
of "libupnp: add 1.8.3 version" patch.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Thomas: fix the dependencies of the Config.in comment.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/libupnp18/Config.in [new file with mode: 0644]
package/libupnp18/libupnp18.hash [new file with mode: 0644]
package/libupnp18/libupnp18.mk [new file with mode: 0644]

index 442dc05199ebdf31cb2fc7c44513be625dcce918..f93c617cf57c1a9ca8f35f361ede582b32e673a2 100644 (file)
@@ -611,6 +611,7 @@ F:  package/gupnp-dlna/
 F:     package/gupnp-tools/
 F:     package/hiredis/
 F:     package/igd2-for-linux/
+F:     package/libupnp18/
 F:     package/minissdpd/
 F:     package/motion/
 F:     package/tinycbor/
index a207de8cc449ad20d727b5ae3bfcaa0783adbc02..4a7327c70c8637f29dec0634b6823649907549f4 100644 (file)
@@ -1383,6 +1383,7 @@ menu "Networking"
        source "package/libtirpc/Config.in"
        source "package/libtorrent/Config.in"
        source "package/libupnp/Config.in"
+       source "package/libupnp18/Config.in"
        source "package/libupnpp/Config.in"
        source "package/liburiparser/Config.in"
        source "package/libvncserver/Config.in"
diff --git a/package/libupnp18/Config.in b/package/libupnp18/Config.in
new file mode 100644 (file)
index 0000000..58508e4
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_LIBUPNP18
+       bool "libupnp18"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_PACKAGE_LIBUPNP
+       help
+         The portable SDK for UPnP(tm) Devices (libupnp) provides
+         developers with an API and open source code for building
+         control points, devices, and bridges that are compliant with
+         Version 1.0 of the Universal Plug and Play Device Architecture
+         Specification
+
+         http://pupnp.sourceforge.net/
+
+comment "libupnp18 needs a toolchain w/ threads"
+       depends on !BR2_PACKAGE_LIBUPNP
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libupnp18/libupnp18.hash b/package/libupnp18/libupnp18.hash
new file mode 100644 (file)
index 0000000..a5b5b07
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed:
+sha256 9afa0b09faa9ebd9e8a6425ddbfe8d1d856544c49b1f86fde221219e569a308d        libupnp-1.8.3.tar.bz2
+sha256 0375955c8a79d6e8fa0792d45d00fc4e7710d7ac95bcbd27f9225a83f5c946fd        LICENSE
diff --git a/package/libupnp18/libupnp18.mk b/package/libupnp18/libupnp18.mk
new file mode 100644 (file)
index 0000000..a75558e
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libupnp18
+#
+################################################################################
+
+LIBUPNP18_VERSION = 1.8.3
+LIBUPNP18_SOURCE = libupnp-$(LIBUPNP18_VERSION).tar.bz2
+LIBUPNP18_SITE = http://downloads.sourceforge.net/project/pupnp/pupnp/libUPnP%20$(LIBUPNP18_VERSION)
+LIBUPNP18_CONF_ENV = ac_cv_lib_compat_ftime=no
+LIBUPNP18_INSTALL_STAGING = YES
+LIBUPNP18_LICENSE = BSD-3-Clause
+LIBUPNP18_LICENSE_FILES = LICENSE
+
+$(eval $(autotools-package))