make needs the full blown gnu glob(), so teach it to use a local copy
authorEric Andersen <andersen@codepoet.org>
Tue, 4 Jul 2006 11:58:51 +0000 (11:58 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 4 Jul 2006 11:58:51 +0000 (11:58 -0000)
package/make/make.mk

index 69eb5a922859d8a5d10d4b8142ec7ad7a6c9ba34..91daf4d59db68dc3811d2d32ca83d2634e18d534 100644 (file)
@@ -24,6 +24,9 @@ $(GNUMAKE_DIR)/.configured: $(GNUMAKE_DIR)/.unpacked
        (cd $(GNUMAKE_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               make_cv_sys_gnu_glob=no \
+               GLOBINC='-I$(GNUMAKE_DIR)/glob' \
+               GLOBLIB=glob/libglob.a \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \