package/ipset: bump to version 7.15
authorPierre-Jean Texier <texier.pj2@gmail.com>
Sat, 14 Aug 2021 19:08:18 +0000 (21:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Aug 2021 20:36:31 +0000 (22:36 +0200)
This includes the following changes:

7.15
    - Kernel part changes
        - netfilter: ipset: Fix maximal range check in hash_ipportnet4_uadt() (Nathan Chancellor)

7.14
    - Userspace changes
        - Add missing function to libipset.map and bump library version (reported by Jan Engelhardt)
    - Kernel part changes
        - 64bit division isn't allowed on 32bit, replace it with shift

7.13
    - Userspace changes
        - When parsing protocols by number, do not check it in /etc/protocols.
        - Add missing hunk to patch "Allow specifying protocols by number"
    - Kernel part changes
        - Limit the maximal range of consecutive elements to add/delete fix

7.12
    - Userspace changes
        - Allow specifying protocols by number (Haw Loeung)
        - Fix example in ipset.8 manpage discovered by Pablo Neira Ayuso.
        - tests: add tests ipset to nftables (Pablo Neira Ayuso)
        - add ipset to nftables translation infrastructure (Pablo Neira Ayuso)
        - lib: Detach restore routine from parser (Pablo Neira Ayuso)
        - lib: split parser from command execution (Pablo Neira Ayuso)
        - Fix patch "Parse port before trying by service name"
    - Kernel part changes
        - Limit the maximal range of consecutive elements to add/delete (reported by Brad Spengler)
        - Backport "netfilter: use nfnetlink_unicast()"
        - Backport "netfilter: nfnetlink: consolidate callback type"
        - Backport "netfilter: nfnetlink: add struct nfnl_info and pass it to callbacks"
        - Backport "netfilter: add helper function to set up the nfnetlink header and use it"

Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ipset/ipset.hash
package/ipset/ipset.mk

index afe83f6dce23a12f0905be2c9f4d886d303f0bdd..9c251be27e745560e645467a9cc94069165bd38b 100644 (file)
@@ -1,4 +1,4 @@
-# From https://ipset.netfilter.org/ipset-7.11.tar.bz2.sha512sum.txt
-sha512  20890de32c17c04d9d3ae42fff64acfe21a252974bee5843ae39bdda707fcef55fde11cffccab9f987bf7e18f5445443c46c50eb854fb6f93f172f7bad07f922  ipset-7.11.tar.bz2
+# From https://ipset.netfilter.org/ipset-7.15.tar.bz2.sha512sum.txt
+sha512  0fc936d971c30a0925c585d506c8840e782fdaeec09bc8fd249e874fe838fa55a4dbb697f6e1423a6769abf07a1ce2195abc37cb641e8e4ad70f1b4c7130916a  ipset-7.15.tar.bz2
 # Locally calculated
 sha256  231f7edcc7352d7734a96eef0b8030f77982678c516876fcb81e25b32d68564c  COPYING
index 07f865d4ec3ed494941738e998c7e6dfb448cf7a..4eda65e81ba331882ae9d842864a43c9d45c273e 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IPSET_VERSION = 7.11
+IPSET_VERSION = 7.15
 IPSET_SOURCE = ipset-$(IPSET_VERSION).tar.bz2
 IPSET_SITE = http://ipset.netfilter.org
 IPSET_DEPENDENCIES = libmnl host-pkgconf