fixup use of a variable before it is set
authorEric Andersen <andersen@codepoet.org>
Fri, 11 Feb 2005 21:02:07 +0000 (21:02 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 11 Feb 2005 21:02:07 +0000 (21:02 -0000)
toolchain/binutils/binutils.mk

index 900060d334b27eeda13964ffeeb1d0d090a20f22..ef9c3dc0a2ac69b31bfb3b5200cde81706d63c0d 100644 (file)
@@ -3,7 +3,7 @@
 # build binutils for use on the host system
 #
 #############################################################
-BINUTILS_VERSION:=$(strip $(BINUTILS_VERSION))
+BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
 
 BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
 ifeq ($(BINUTILS_VERSION),2.15)
@@ -132,9 +132,3 @@ binutils_target-clean:
 
 binutils_target-dirclean:
        rm -rf $(BINUTILS_DIR2)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))