added gnuchess
authorJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:10:50 +0000 (18:10 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:10:50 +0000 (18:10 -0000)
package/gnuchess/Config.in [new file with mode: 0644]
package/gnuchess/gnuchess-5.07.patch [new file with mode: 0644]
package/gnuchess/gnuchess.mk [new file with mode: 0644]

diff --git a/package/gnuchess/Config.in b/package/gnuchess/Config.in
new file mode 100644 (file)
index 0000000..3919c25
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_GNUCHESS
+       bool "gnuchess"
+       default n
+       help
+         GNU Chess lets most modern computers play a full game of chess.
+
+         http://ftp.gnu.org/pub/gnu/chess
diff --git a/package/gnuchess/gnuchess-5.07.patch b/package/gnuchess/gnuchess-5.07.patch
new file mode 100644 (file)
index 0000000..18979b6
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/input.c      2003-07-01 13:06:43.000000000 -0400
++++ a/src/input.c      2008-02-13 12:24:43.000000000 -0500
+@@ -92,7 +92,7 @@ void getline_standard(char *p)
+   fgets(inputstr, MAXSTR, stdin);
+ }
+-static pthread_t input_thread;
++pthread_t input_thread;
+ /* Mutex and condition variable for thread communication */
diff --git a/package/gnuchess/gnuchess.mk b/package/gnuchess/gnuchess.mk
new file mode 100644 (file)
index 0000000..8a64d89
--- /dev/null
@@ -0,0 +1,18 @@
+#############################################################
+#
+# gnuchess
+#
+#############################################################
+GNUCHESS_VERSION = 5.07
+GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
+GNUCHESS_SITE = http://ftp.gnu.org/pub/gnu/chess
+GNUCHESS_AUTORECONF = NO
+GNUCHESS_INSTALL_STAGING = NO
+GNUCHESS_INSTALL_TARGET = YES
+
+GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
+
+GNUCHESS_DEPENDENCIES = uclibc 
+
+$(eval $(call AUTOTARGETS,package,gnuchess))
+