Makefile: add alldefconfig target
authorArnout Vandecappelle <arnout@mind.be>
Fri, 21 Jul 2017 01:05:29 +0000 (03:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 25 Jul 2017 21:06:58 +0000 (23:06 +0200)
It is used by Kconfig's merge_config.sh.

No alldefpackageconfig is added, since it's rather pointless: it would
only enable busybox.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 3712e47c9dc6374d3c48cdc4c9db8f015dd59f1d..4251803e748e67d863c4fc369e05e9c1b448437f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -128,7 +128,7 @@ export BR2_VERSION_FULL := $(BR2_VERSION)$(shell $(TOPDIR)/support/scripts/setlo
 
 # List of targets and target patterns for which .config doesn't need to be read in
 noconfig_targets := menuconfig nconfig gconfig xconfig config oldconfig randconfig \
-       defconfig %_defconfig allyesconfig allnoconfig silentoldconfig release \
+       defconfig %_defconfig allyesconfig allnoconfig alldefconfig silentoldconfig release \
        randpackageconfig allyespackageconfig allnopackageconfig \
        print-version olddefconfig distclean manual manual-%
 
@@ -886,7 +886,7 @@ config: $(BUILD_DIR)/buildroot-config/conf prepare-kconfig
 # no values are set for the legacy options so a subsequent oldconfig
 # will query them. Therefore, run an additional olddefconfig.
 
-randconfig allyesconfig allnoconfig: $(BUILD_DIR)/buildroot-config/conf prepare-kconfig
+randconfig allyesconfig alldefconfig allnoconfig: $(BUILD_DIR)/buildroot-config/conf prepare-kconfig
        @$(COMMON_CONFIG_ENV) SKIP_LEGACY=y $< --$@ $(CONFIG_CONFIG_IN)
        @$(COMMON_CONFIG_ENV) $< --olddefconfig $(CONFIG_CONFIG_IN) >/dev/null
 
@@ -996,6 +996,7 @@ help:
        @echo '  savedefconfig          - Save current config to BR2_DEFCONFIG (minimal config)'
        @echo '  allyesconfig           - New config where all options are accepted with yes'
        @echo '  allnoconfig            - New config where all options are answered with no'
+       @echo '  alldefconfig           - New config where all options are set to default'
        @echo '  randpackageconfig      - New config with random answer to package options'
        @echo '  allyespackageconfig    - New config where pkg options are accepted with yes'
        @echo '  allnopackageconfig     - New config where package options are answered with no'