vte: new package
authorStefan Fröberg <stefan.froberg@petroprogram.com>
Tue, 16 Jan 2018 23:15:58 +0000 (01:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Apr 2018 21:29:02 +0000 (23:29 +0200)
The VTE package contains a termcap file implementation for
terminal emulators.

Signed-off-by: Stefan Fröberg <stefan.froberg@petroprogram.com>
[Thomas: fix encoding of license name.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/vte/Config.in [new file with mode: 0644]
package/vte/vte.hash [new file with mode: 0644]
package/vte/vte.mk [new file with mode: 0644]

index 45a8979e97befd89b8367bf33bf9eecf4e60eae1..f270db5bb3e25c30648fa1fd2916aeae230f27eb 100644 (file)
@@ -1768,6 +1768,7 @@ N:        Stefan Fröberg <stefan.froberg@petroprogram.com>
 F:     package/elfutils/
 F:     package/libtasn1/
 F:     package/proxychains-ng/
+F:     package/vte/
 F:     package/yasm/
 F:     package/zlib-ng/
 
index 8be48816e68c1dca8a7411afe6bec6d7f7996d33..d3b67d40dec0a6d2392e723f388fbb6dd19407c1 100644 (file)
@@ -340,6 +340,7 @@ comment "X applications"
        source "package/qt-webkit-kiosk/Config.in"
        source "package/rdesktop/Config.in"
        source "package/synergy/Config.in"
+       source "package/vte/Config.in"
        source "package/wmctrl/Config.in"
        source "package/x11vnc/Config.in"
        source "package/xdotool/Config.in"
diff --git a/package/vte/Config.in b/package/vte/Config.in
new file mode 100644 (file)
index 0000000..7410624
--- /dev/null
@@ -0,0 +1,33 @@
+config BR2_PACKAGE_VTE
+       bool "vte"
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
+               BR2_PACKAGE_HAS_LIBGL
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_LIBGTK3
+       select BR2_PACKAGE_LIBXML2
+       select BR2_PACKAGE_PCRE2
+       help
+         VTE is a library (libvte) implementing a terminal emulator
+         widget for GTK+, and a minimal sample application (vte)
+         using that. Vte is mainly used in gnome-terminal, but
+         can also be used to embed a console/terminal in games,
+         editors, IDEs, etc.
+
+         http://github.com/GNOME/vte
+
+comment "vte needs a toolchain w/ wchar, threads, C++"
+       depends on BR2_USE_MMU
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_HAS_THREADS
+
+comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"
+       depends on BR2_USE_MMU
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND && \
+               !BR2_PACKAGE_HAS_LIBGL
diff --git a/package/vte/vte.hash b/package/vte/vte.hash
new file mode 100644 (file)
index 0000000..3fbc5ac
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 a3a9fb182740b392a45cd3f46fa61a985f68bb6b1817b52daec22034c46158c3  vte-0.48.3.tar.xz
+sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
diff --git a/package/vte/vte.mk b/package/vte/vte.mk
new file mode 100644 (file)
index 0000000..90853cb
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# vte
+#
+################################################################################
+
+VTE_VERSION = 0.48.3
+VTE_SOURCE = vte-$(VTE_VERSION).tar.xz
+VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
+VTE_DEPENDENCIES = host-pkgconf libgtk3 libxml2 pcre2
+VTE_LICENSE = LGPL-2.1+
+VTE_LICENSE_FILES = COPYING
+VTE_CONF_OPTS += --disable-introspection --without-gnutls --disable-vala
+
+$(eval $(autotools-package))