qt5: install headers into /usr/include/qt5
authorFatih Aşıcı <fatih.asici@gmail.com>
Tue, 24 Dec 2013 06:53:57 +0000 (08:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Dec 2013 17:14:27 +0000 (18:14 +0100)
There are places in Qt's source where headers included with the name of
the module subdirectory (e.g. #include <QtCore/QHash>). Therefore, the
build system passes the top header directory to the compiler; but this
results in a error when building host tools since sysroot/usr/include
directory includes architecture specific system headers.

In order to prevent this, install all Qt headers into a subdirectory in
/usr/include.

Fixes: http://autobuild.buildroot.net/results/4f1/4f16c0b38bdd6e40efcc781c12fae81c0bfabb72/
Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5base/qt5base.mk

index 1b753d3f5b6e0e164d842091f5315593274275c1..e46bdebe550f60cd1d14fdd8309d4429970009ac 100644 (file)
@@ -159,6 +159,7 @@ define QT5BASE_CONFIGURE_CMDS
                -v \
                -prefix /usr \
                -hostprefix $(HOST_DIR)/usr \
+               -headerdir /usr/include/qt5 \
                -sysroot $(STAGING_DIR) \
                -plugindir /usr/lib/qt/plugins \
                -no-rpath \