linux: build after linux-firmware if enabled for early loading support
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Feb 2021 16:05:57 +0000 (17:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 23 Feb 2021 12:50:06 +0000 (13:50 +0100)
To support building in (a subset of) the linux-firmware files into the
kernel using the CONFIG_EXTRA_FIRMWARE option, we need to ensure that the
firmware files are installed before the Linux kernel is built, similar to
how it is done for intel-microcode.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index a212f42c284e286fc0af3f23505e2878564ecd40..5e4b319cf1bc4eba833e843ffe780e834de19449 100644 (file)
@@ -78,7 +78,8 @@ LINUX_MAKE_ENV = \
 
 LINUX_INSTALL_IMAGES = YES
 LINUX_DEPENDENCIES = host-kmod \
-       $(if $(BR2_PACKAGE_INTEL_MICROCODE),intel-microcode)
+       $(if $(BR2_PACKAGE_INTEL_MICROCODE),intel-microcode) \
+       $(if $(BR2_PACKAGE_LINUX_FIRMWARE),linux-firmware)
 
 # Starting with 4.16, the generated kconfig paser code is no longer
 # shipped with the kernel sources, so we need flex and bison, but